Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have this problem with all of my music player applications Banshee, Guayadeque and Amarok -when I click the Play button nothing happens, i.e. music doesnt start playing or the Play button doesnt change to a Pause button etc... Playback in all of the applications was fine yesterday.

Everything is setup as it should be in sound preferences and speaker tests work fine.

Ive been using linux/ubuntu on and off for a few years, but still consider myself a relative noob, so theres probably some vital info missing -let me know if there is Ill update ASAP.

Sound card in use: Creative Technology SB Live! 24-bit External

aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC889A Analog [ALC889A Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC889A Digital [ALC889A Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: External [SB Live! 24-bit External], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

lsmod | grep snd

snd_hda_codec_hdmi     27535  1 
snd_hda_codec_realtek   255882  1 
snd_usb_audio          91410  2 
snd_hda_intel          28209  2 
snd_hda_codec          90901  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_pcm                80042  4 snd_hda_codec_hdmi,snd_usb_audio,snd_hda_intel,snd_hda_codec
snd_hwdep              13274  2 snd_usb_audio,snd_hda_codec
snd_usbmidi_lib        24388  1 snd_usb_audio
snd_seq_midi           13132  0 
snd_seq_midi_event     14475  1 snd_seq_midi
snd_rawmidi            25269  2 snd_usbmidi_lib,snd_seq_midi
snd_seq                51291  2 snd_seq_midi,snd_seq_midi_event
snd_timer              28659  2 snd_pcm,snd_seq
snd_seq_device         14110  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    55295  20 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_usb_audio,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_usbmidi_lib,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore              12600  1 snd
snd_page_alloc         14073  2 snd_hda_intel,snd_pcm

cat /proc/asound/version

Advanced Linux Sound Architecture Driver Version 1.0.23.

cat /proc/asound/cards

 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xe9300000 irq 48
 1 [External       ]: USB-Audio - SB Live! 24-bit External
                      Creative Technology SB Live! 24-bit External at usb-0000:00:1a.1-1, full speed
 2 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xe5010000 irq 49
share|improve this question
1  
What about sound in webpages such as YouTube? Is this sound problem limited to audio players? If so, does anything suspicious show up in the log if you run Banshee from Terminal with the command banshee --debug? –  michaelms Sep 12 '11 at 18:30
    
Embarrasing -my music is stored on an NTFS drive which I deciced to permanently mount yesterday albiet with a different path... I learnt something though --debug, I still find it odd that none of the apps GUIs through up an error. –  volting Sep 12 '11 at 21:19
    
I think I screwed up my audio preferences applet in the process of trying to fix it after reinstalling + purging PA and Alsa, the applet is missing from the panel –  volting Sep 12 '11 at 21:22
add comment

1 Answer 1

up vote 2 down vote accepted

I solved the problem thanks to @MichaelMS, -I have my music stored on an NTFS drive which I deciced to permanently mounted (so that I could access it with SSHFS) but with a different path then that used by Ubuntu when... So then none of audio player apps could find the music.

I find it strange that none of the apps GUIs show an error for this type of scenario -such as a little error dialog -eh where has your music gone...!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.