Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I seen many times how people describe how to's about LBP-2900, and 10-12 steps from start to end of how to download, unpack, build driver, fix driver, make it work... Could be there some .deb package with ready-to-go driver for Ubuntu? This printer is very popular...

share|improve this question
See also: How to make LBP-1120 Canon printer work? – cipricus Jan 27 '13 at 21:58

For the printer, there is a script that should help you do this with little effort - my source is here.

You need to download the script from the Canon Website (you will need to extract this archive). Running the script from a terminal is easy: sudo ./ LBP2900

share|improve this answer
Thank you for the script. – Vitaly Dyatlov Oct 21 '10 at 11:11
The script can be found here:… – david6 Nov 23 '11 at 0:23

What did you do so far?

Setting up a LBP-Printer recently, I had to replug the USB after installing, and to restart ccpd.

Configure your printer in the browser: http://localhost:631/admin

Then, in a Shell, do:

sudo /etc/init.d/ccpd status 
sudo /etc/init.d/ccpd restart
sudo /etc/init.d/ccpd status 
share|improve this answer

For 11.10

I installed a Canon-LBP- printer on my sisters Ubuntu machine. It was a hard riddle, involving several downloads, unplugging and replugging the USB, and finally it printed, but refused to print after reboot.

There are two daemons to be started in /etc/init.d which were installed to automatically start, but sometimes, one of them, failed.

Do a

ps -c ccpd

to check, whether ccpd was started and is running, and if not

sudo /etc/init.d/ccpd restart

If it is running,

sudo /etc/init.d/ccpd status 

which should show two port numbers. Afaik, I had to restart ccpd

sudo /etc/init.d/ccpd restart

to bring the printer back. In /var/log/cups/error_log you could find more informations about errors. The first character means:

  • d debug
  • i information
  • w warning
  • e error

with increasing severity to the bottom. Maybe you have to activate logging and increase the loglevel (direction up) to get more information.

share|improve this answer
thank, I will try this. – RAMESH Nov 2 '11 at 16:35

For 13.10

  1. Clean install the Ubuntu 13.10

  2. Download the drivers from the following link

    (Remember that there are many other scrips also from radu (other versions) and other writers, which I have tried but none of that worked for me on Ubuntu 13.10)

  3. Extract the files

  4. Follow the instruction in readme file or

    Open terminal, CD to the folder where files are extracted run the command

    $sudo ./ LBP2900

    (Replace the printer number of your printer LBPXXXX)

  5. Open System Settings -> Printer -> set “LBP2900” printer as Default

  6. Restart PC


share|improve this answer
I Done but it didn't work. It returned an error as same as this one. – mini Dec 30 '13 at 9:47
There have been some effort for an out-of-the-box script here : (CAPT 2.60) – Hugolpz Jan 2 '15 at 21:37

protected by jokerdino Nov 29 '13 at 15:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.