Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Motorola S305 Bluetooth headset which I use with my computer often for headphones. I've been using them for a while and have been really pleased with the sound quality, form factor, and battery life.

The only thing is that I haven't found a way to use them as a microphone yet. Is there a way for me to use them for a microphone so that I can seamlessly use them for Skype and other applications?

share|improve this question

4 Answers 4

up vote 7 down vote accepted

From the Sound Preferences menu we select the Input tab to choose our Bluetooth device (here depicted for a Philips headset) for audio input:

enter image description here

In order to use your headset for telephony we will also have to make sure, that the hardware is set to Duplex mode in Hardware -> Settings:

enter image description here

Note: In duplex mode the sound quality may not be very high due to usage of the HSP/HFP codecs.

share|improve this answer
2  
Yep, that's it. Unfortunately, it makes sound quality horrible if trying to play anything other than a phone call. –  Naftuli Tzvi Kay Sep 14 '11 at 22:22
    
For "better" sound quality choose A2DP for playback (however still this may be far from CD quality). The microphone unfortunately is not available in A2DP mode. –  Takkat Sep 15 '11 at 6:19
    
Roger that. It's just a bummer that no mode exists to make the microphone available over A2DP. –  Naftuli Tzvi Kay Sep 15 '11 at 6:20
    
Unfortunately I have no experience (yet) on that but it may be possible that by introducing L2CAP in Linux kernel 3.0 (11.10) this feature could be made available (if somebody codes drivers). –  Takkat Sep 15 '11 at 6:44
1  
@Tapper: This is a limtation of the A2DP specification. –  Takkat Sep 29 '12 at 17:40

I have no explicit solution but the bug ticket for this: #508522

Perhaps sometimes there will be the solution for this issue.

share|improve this answer

If you open the sound menu and select "Audio preferences", then you'll get a dialog where one of the pages is called "Inputs" or similar. You should be able to see your headphones as an input source there.

share|improve this answer

Just try talking into the headsets and see if it work.

share|improve this answer
    
Lol. You win the "Sarcastic Answer of the Year" award! –  Naftuli Tzvi Kay Sep 15 '11 at 6:21
    
This is really a comment, not an answer to the question. Please use "add comment" to leave feedback for the author. –  Stephen Myall Aug 16 '12 at 16:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.