Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a 16 GB 1.0 USB Stick in titanium with leather bound, which i happen to love. I know it works in Vista (of all things) but in Ubuntu 11.04 (i also have gnome 3, if that may affect, but am fairly certain I tried before) it is not detected. I have also run sudo commands in the terminal to search for it and it does not show up, nor when I login as root.

Due to the slow speed I only use it for HTML/CSS/PHP and a backup of Software Setups in case I break something and need to get my setup back without an internet connection.

Toshiba Satellite-Pro L300 1F-J (with upgraded RAM).
3 USB 2.0 Ports, 2 on the left, one on the right, all tested.

$ sudo lsusb generates:

Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 0011:7788
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

$ dmesg appends:

[ 79.868026] usb 2-3: new high speed USB device using ehci_hcd and address 2
[ 80.150509] usbcore: registered new interface driver uas
[ 80.174803] Initializing USB Mass Storage driver...
[ 80.174934] scsi6 : usb-storage 2-3:1.0
[ 80.175941] usbcore: registered new interface driver usb-storage
[ 80.175945] USB Mass Storage support registered.
[ 81.184276] scsi 6:0:0:0: Direct-Access Generic Flash Disk 8.00 PQ: 0 ANSI: 2
[ 81.184790] sd 6:0:0:0: Attached scsi generic sg2 type 0
[ 81.187989] sd 6:0:0:0: [sdb] 32768000 512-byte logical blocks: (16.7 GB/15.6 GiB)
[ 81.188829] sd 6:0:0:0: [sdb] Write Protect is off
[ 81.188834] sd 6:0:0:0: [sdb] Mode Sense: 03 00 00 00
[ 81.188836] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[ 81.191324] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[ 81.207084] sdb:
[ 81.212388] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[ 81.212395] sd 6:0:0:0: [sdb] Attached SCSI removable disk

share|improve this question
It should be detected, when you plug it does running lsusb give you something?. – Uri Herrera Sep 11 '11 at 20:41
@Lewise - reboot without your stick inserted. Type dmesg - note the [ ...time... ]. Insert your USB stick and type dmesg - copy and paste the new output you see from [ ...time...] into your question. This will hopefully give us a clue as to how the Kernel is dealing with your USB stick. – fossfreedom Sep 14 '11 at 14:19
@fossfreedom appended dmesg output added. – Lewis Goddard Sep 15 '11 at 11:47
up vote 9 down vote accepted

USB 1.0 is upward compatible so this should not be a problem.

It's possible that the partition table on the USB stick is corrupted and that Windows is being less picky about it than Linux.

See if the "Disk Utility" application (palimpsest) shows your hardware when you connect it. See if it recognises the partitions. See if the "Mount Volume" button works.

If it's seeing the hardware OK, one thing you could try is

  • Backup the files on the stick from Windows
  • Boot into Linux
  • Reformat and repartition the drive from palimpsest
  • Copy the files back onto it from Windows

Some USB sticks are supplied with custom partition schemes (like U3 sticks) and this might also be confusing things - again, you could try repartitioning the drive.

share|improve this answer
Disk Utility does not show it. I booted vista and ran chkdsk, which reported no errors or bad sectors. I formatted under Disk Management, it refused to format as NTFS, returning an error at the end, but worked fine in FAT32, which was what it was originally in. It still is not detected by Ubuntu, even in Disk Utility – Lewis Goddard Sep 12 '11 at 17:55
I'm marking this as my solution, not because it fixed it, but because it answers the original question the best. – Lewis Goddard Sep 14 '11 at 14:22
Revisiting this some time later : some sticks, I have only been able to revive by directly wiping the first few thousand blocks by using dd to copy /dev/zero over the device, destroying ANY partition data, including corrupted partition tables. Note that this obviously destroys any data on the drive. – Adrian Dec 1 '14 at 17:27

To answer your title, yes, Ubuntu (11.xx or anything) supports USB 1.0, so the problem is probably somewhere in your BIOS.

Ensure that you have legacy USB support enabled (if your BIOS has the option). If that is enabled, then it is likely a software related issue, and you should report a bug in that case.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.