Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

/etc/fstab

192.168.0.14:/media/hdd500         /mnt/sosonicoco      nfs user,auto 0 0
192.168.0.14:/media/hdd500/Musique /home/nicoco/Musique nfs user,auto 0 0

sosonicoco is seen by nautilus as a normal directory, but Musique appears as a umountable device, even though I have an error message stating I need root privileges to umount it when I click its eject button.

How can I avoid nautilus to list this Musique mounted NFS directory here?

It also appears in Unity launcher, which is even more annoying

share|improve this question
add comment

1 Answer

From the mount man page:

The non-superuser mounts.
       Normally,  only  the  superuser can mount filesystems.  However,
       when fstab contains the user option on a line, anybody can mount
       the corresponding system.

       Thus, given a line

              /dev/cdrom  /cd  iso9660  ro,user,noauto,unhide

       any  user  can  mount  the iso9660 filesystem found on his CDROM

As you've set the user option for those mounts in /etc/fstab, they are mountable/unmountable by ordinary users. If you remove that option, then Nautilus shouldn't consider those volumes user unmountable.

share|improve this answer
    
thanks, I was just confused by the fact that the other share, with the same options, didn't appear –  Nicoco Sep 11 '11 at 16:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.