Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Problem:
Nvidia X-server settings offers me 1152x864 and 1360x768, but not the value 1280x1024 in-between that I need.
How can I get the proper resolution (1280x1024) on Nvidia ION with Ubuntu 11.04?

Background:
I've asked this question before, but using a different computer. Now, I'm on a new computer (=new GPU) and the troubles have reappeared. It's evident by now that the root problem is that my monitor is not delivering proper EDID information to the computer, but I do not want to buy a new monitor, so I'm trying to find a software solution to make Ubuntu send the correct output. I had a working solution on 10.04 but editing the /etc/X11/xorg.conf file in section "Monitor" doesn't seem to work now, though it did back on 9.04.
Also, fiddling with 'xrandr' used to work (although badly and without acceleration, but doesn't work at all on this version, and Oli mentions that 'xrandr' doesn't work with the closed Nvidia drivers anyway so that's not where I should be looking.

Data:

  • My monitor is an LCD panel: vendor is BenQ, model T905, with 1280x1024 resolution at 60Hz, connected via a normal VGA cable.

  • In the control panel's "Additional Hardware", it says that the "Nvidia accelerated graphics driver [current version] (Recommended)" is "activated but not currently in use". There's a button to remove it, but no button to put it "in use".

  • I've edited xorg.conf as described in an earlier solution, but this doesn't seem to change anything even after a reboot:

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "BenQ"
    ModelName "T905"
    HorizSync 31.0 - 81.0
    VertRefresh 56.0 - 76.0
    EndSection

  • $ cvt 1280 1024 60 results in:

    1280x1024 59.89 Hz (CVT 1.31M4) hsync: 63.67 kHz; pclk: 109.00 MHz Modeline "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync

  • The output of xrandr -q contains the error:

    xrandr: Failed to get size of gamma for output default

share|improve this question

1 Answer 1

up vote 4 down vote accepted

This is how I can fix it, but I have to re-do these steps after every reboot:
Can anyone edit in the steps to make this stick across reboots?

  • run sudo nvidia-xconfig
  • reboot
  • with sudo, edit the file "/etc/X11/xorg.conf" and replace the two lines ("HorizSync" and "VertRefresh") with the following:

HorizSync 31.0 - 81.0
VertRefresh 56.0 - 76.0

  • Restart
  • Start "Nvidia X Server Settings" again
  • Now the "Resolution" dropdown listbox contains many more entries, and 1280x1024 is among them. Select it and press button "Apply" then "OK".
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.