Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For a few days, a lot of programs do not launch properly. This includes Skype, Oracle VM Virtualbox, Scilab, Boinc, LÖVE, OMG! Words! and a little Java program I downloaded from the web (RemoteDroid). When I launch them from the terminal, I get the same error: Segmentation fault.

I cannot figure out which is the recent change I made on my computer that is the origin of those errors; is it because I changed my keyboard-layout? Or because I installed a lot of programs for developers?

Notice that it is a general problem, not for just one only application. Moreover, since the two first are closed source, I will not be able to compile them.

share|improve this question
Segmentation faults occur when a program crashes because some part of its code is buggy and tried accessing a memory location when it is not able to. If you see this occurring, you should file a bug for it, as these are programming errors that definitely need to be fixed. – Christopher Kyle Horton Sep 11 '11 at 5:02
up vote 6 down vote accepted

Either you recently upgraded a library that the programs share to a new, buggy version, or you have developed a hardware problem, such as overheating.

share|improve this answer
What do you suggest? That I reinstall the whole OS? That I change my computer? – Agmenor Sep 15 '11 at 6:05
@Agmenor, make sure your computer isn't clogged with dust that could be making it overheat, and yes, a reinstall wouldn't hurt. See if you still have problems without updating. – psusi Sep 15 '11 at 13:37
Reinstall of Ubuntu solved the problem. – Agmenor Sep 25 '11 at 22:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.