Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 10.10, and am trying to upgrade Shotwell to the latest version (0.11.1). I've been trying to follow the instructions on the Shotwell installation page for building from source but I have run into a problem.

When I run make, I get the following message:

Requested 'gstreamer-pbutils-0.10 >= 0.10.32' but version of GStreamer Base Utils Library is 0.10.30
make: *** [pkgcheck] Error 1

It seems like the problem is that I need a newer version of GStreamer, but I'm not sure. What should I do from this point?

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

There is a PPA on launchpad which the maintainer supports for new shotwell releases for both Lucid and Maverick.

sudo apt-add-repository ppa:flexiondotorg/shotwell
 sudo apt-add-repository ppa:gstreamer-developers/ppa
 sudo apt-get update
 sudo apt-get dist-upgrade
 sudo apt-get install shotwell

As you can see - it does involve upgrading to the latest gstreamer from the gstreamer developers themselves.

So you could have two choices:

  1. Install just that gstreamer PPA and then compile your shotwell code from source or...
  2. Install both PPA's and have the "almost" newest version of Shotwell available!

As for all PPA's - they can make your system unstable, so have a backup before installing - or use ppa-purge to remove misbehaving PPAs.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.