Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an old dell desktop running ubuntu 11.04, I also have samba installed on it. I'm trying to access the shared folders on the Ubuntu machine from my Mac, so I go into 'Finder', click on 'Go' and 'Connect to Server'.

I type in the ip address of the ubuntu machine smb://xxx.xxx.x.xx and click connect, I can then see the list of shared folders from the ubuntu machine so I know its making a connection. But when I access the 'Music' folder I get an error message stating:

There was an error connecting to the server "xxx.xxx.x.xx". Check the server name or IP address, and try again.

Any thoughts anyone ?

EDIT I have a external hard drive attached to the server, and the folders I'm trying to access are located on that external hard drive.

The location of the folder is /media/HD-CELU2/test, so I think the path from Finder should be smb://xxx.xxx.x.xx/media/HD-CELU2/test, but having tested this, I'm still not getting in.

P.S. I'm using Samba as I have a Windows machine on my home network as well.

share|improve this question

migrated from stackoverflow.com Sep 10 '11 at 14:54

This question came from our site for professional and enthusiast programmers.

    
... and you have no problems with Samba using Windows or Ubuntu? That sounds to me like you have a problem with your Mac. –  Jo-Erlend Schinstad Sep 11 '11 at 23:13
    
Sorry Jo, I didn't explain myself very will in the original post, I'm trying to access the shared folders on Ubuntu machine from my mac book pro. I've edited the post accordingly. –  Stephen Sep 13 '11 at 18:53

3 Answers 3

I would go on the Mac to the net info then to machines and search for ubuntu pcs name and copy that name use it instead of the ip adress. In Finder do: Go - Connect to and then smb://name/user You of course have to have your samba server configured right. If that doesn't work do the following:

 sudo gedit /etc/samba/smb.conf

Rename MSHOME to WORKGROUP

Then got to the line where the security is defined and add ; at the beginning of the line. Save and restart samba with:

sudo /etc/init.d/samba restart

Now create a user with:

sudo smbpasswd -a yourname

Now got to the network settings and give your Server IP, subnet mask and gateway.

And then redo the things I first said.

Forgot to say it but you have to right click the folder you want to share then left click on sharing options and tick everything. Since you have set up a user you dont have to tick the last one.

share|improve this answer

I suggest that you use sshfs. You need to have a ssh server (ssh-server package) and the sshfs package installed your Ubuntu server and a ssh client installed on your Mac.

sshfs on Ubuntu Server: https://help.ubuntu.com/community/SSHFS

ssh on Mac OS X: http://www.panix.com/help/sw.macosx-ssh.html

Then on your Mac, go to Finder --> Connect to server. Enter the ip address of the server and the port number on which the ssh server is listening (default 22), your username and password of your account on the Ubuntu server and the folder to access (/media/HD-CELU2/test).

Once you are connected, I suggest that you setup a ssh key-pair between your Mac and your Ubuntu server, so that you do not need to enter your username or password next time that you connect.

share|improve this answer

Click the Desktop go to GoNetwork (Command + Shift + K if it's not there, it's months since I've used a Mac!), the Mac will then hunt down all network shares on the LAN.

If that doesn't pick it up try smb://hostname where hostname is the name of the sharing computer. I don't know why, but typing smb://ipaddress has never worked for me on any OS.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.