Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ralink Technology publishes their drivers in source code form on their website here. When complied with make and make install in 10.04, the drivers worked well in 32 and 64 bit versions of Lucid. However, when compiled for the 64 bit version of Maverick, it does not work at all, and 32 bit Maverick, it works but randomly disconnects.

Both versions of Maverick say "[Proprietary] Driver is activated but not in use" in the Proprietary Drivers dialog.

Do the drivers just need to be updated? Is there an easy fix?

share|improve this question
    
Stranger still, on my netbook, the 32-bit version's drivers work out of the box when using a flash drive, but not at all (until I install them from the website) using a live cd of the same image. –  xd1936 Oct 13 '10 at 20:49
    
Same here, RT3090-PPA x64 has been installed but not working. If we push/load manually, the display apparently freeze. –  Code System Jan 30 '11 at 17:10
    
Alternatively you can install latest sets of patches from openwrt trunk –  BigSack Jun 7 '12 at 8:40

3 Answers 3

From the bug report post #103 work fine on a MSI U210:

Go to your terminal and type in this command: lsmod | grep rt

Your output will look something similar to this one:

rt2860sta 488820 0 
rt2800usb 37372 0 [...]

open your Terminal and first type in this:

 sudo modprobe rf rt2800pci
 sudo modprobe -rf rt2860sta
 sudo modprobe rt2860sta

Just as you type in this, your networkmanager connects automatically and works! But to close the whole thing up, you need to type in this command:

echo blacklist rt2800pci | sudo tee -a /etc/modprobe.d/blacklist.conf

Then you are done and your networkmanager will work for you again.

share|improve this answer
    
Thank you!!! it worked!! lyhana8!!! It was a problem with the modules. Changing the loading modules order all works perfect!! So simple and easy to do, without compiling anything at all (In meerkat - Ubuntu 10.10) –  Jesus Jan 30 '11 at 17:08

I also have Ralink RT3090 wifi on my laptop. I'm using Kubuntu 10.10 64-bit. I installed driver from source, after installation (K)ubuntu loads 2800pci version instead of 3090sta. You have to fix it by manually editing some files.

Open /etc/modprobe.d/blacklist.conf (as root) and add at the end:

blacklist rt2800pci.

Also open (as root) file /etc/modules and add:

rt3390sta

I followed this post and it is working now.

share|improve this answer

I would also suggest doing this:

lsmod | grep ^rt

How many rt modules are running on your system? If it is more than one, it may be conflicting. I have a RAlink card, and initially, two rt modules were both trying to use my card, and the conflict made networking unusable. I blacklisted one of them, and now it works fine. This is for RAlink and not RT3090, so YMMV.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.