Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was playing around in Unity 2D, and I messed up my configuration. How can I reset it, preferably without losing other config files? (such as Empathy config, Firefox/Chrome config, etc)

share|improve this question
    
@type: That restarts - I want to reset. For Unity, a simple unity --reset will do the trick - I want the equivalent for Unity 2D. –  jrg Sep 9 '11 at 18:49
    
@jrg - can you clarify what you mean "messed up my configuration" - what is wrong? Can you post a picture in your question? –  fossfreedom Sep 9 '11 at 21:49
    
@fossfreedom It's a hypothetical question - similar to How do I reset my Unity configuration and How do I reset GNOME? - it's a legitimate question though. –  jrg Sep 10 '11 at 0:48
    
Purge unity-2D and reinstall it –  Tachyons Oct 27 '12 at 4:09
1  
@tachyons That answer has been given on several occasions, but it doesn't remove user specific configuration. –  jrg Oct 27 '12 at 16:38
add comment

4 Answers 4

To reset unity type the following in the terminal:

unity --reset

To reset the unity icons type:

unity --reset-icons

To reset Compiz type (NOTE: this will reset ALL compiz settings):

   gconftool-2 --recursive-unset /apps/compiz-1
unity --reset

The above command will reset the respective elements back to their default configuration.

share|improve this answer
1  
Nope, that's for normal Unity. This is for Unity 2D, not 3D. Thanks for the answer though, it's already documented here –  jrg Sep 9 '11 at 16:38
    
Also, resetting compiz doesn't apply here, since Unity 2D uses metacity - Unity 3D is just a giant compiz plugin. –  jrg Sep 9 '11 at 16:45
    
Yes. I wasn't thinking at the time I guess ;) –  Adam Thompson Sep 10 '11 at 4:34
add comment

Open a terminal and type

dconf reset -f /

to reset Unity 2D to defaults, or IMPORTANT - THIS RESETS EVERYTHING NOT JUST UNITY-2D

unity --reset

to reset Unity (3D).

If default Ubuntu Nautilus theme is also missing, close all instances and type

rm -R ~/.gconf/apps/nautilus
share|improve this answer
2  
THIS RESETS EVERYTHING - do not use this on a casual basis! –  fossfreedom Dec 17 '11 at 17:04
add comment

if the close, maximize and minimize disapeared, try this:

  1. press Ctrl+Shift+F2;
  2. Login with your username and password;
  3. type this command: sudo restart lightdm
share|improve this answer
    
I think you mean Ctrl+_Alt_+F2. Your solution will simply restart the login manager, which a reboot will also do. –  Ramchandra Apte Dec 18 '13 at 13:01
add comment

Although this link may seem off topic, it covers some of the information I believe you are looking for.

Edit: Whoops, I see fossfreedom was already on the case.

Changing Unity Default Settings

User: fossfreedom points out,

The list of sessions is described in the directory:

/usr/share/xsessions

For unity-2d the session file is called:

ubuntu-2d.desktop

fossfreedom goes on to explain how to reset this to default. Hopefully, this method would leave your files intact.

Regards, SomaComa

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.