Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The Unity launcher tends to put itself in the background of any windows sometimes.

It does not occur on startup, just randomly after some hours of usage.

How do I bring it back to front without restarting my computer/destroying my gdm session?

a.

It was hard to get a picture of both the dash and the launcher since the dash captures the PRT SCRN key. Although the dash will hide behind any other windows too.


After some further use, my pc froze for a brief moment (it's under heavy load from render jobs), now dash and launcher shows correctly in front of everything.

share|improve this question
    
Is this on 11.10 or 11.04? –  jrg Sep 9 '11 at 15:29
    
@jrg - It is on 11.04 –  joar Sep 9 '11 at 16:17
    
Ok, thanks. That'll help a bit. –  jrg Sep 9 '11 at 16:31

3 Answers 3

up vote 14 down vote accepted

I found this solution from comment #15 in an Ubuntu bug report:

After this bug occurs, restarting unity by "unity& disown" in a terminal fixes the problem

There there is a duplicate bug here

share|improve this answer
    
I had to wait until it occured again to test it, it just happend, and running unity& disown solved the problem, although the position of some windows (esp. Terminals) across desktops was changed. –  joar Sep 23 '11 at 13:14
1  
The workaround of "unity& disown" worked for me. –  Sqeaky Oct 15 '11 at 19:46
    
Workaround works in 12.10 as well. –  Matt Hulse Mar 11 '13 at 20:14
    
Worked on 13.04, but the windows thru workspaces got messed up. –  robertokl May 9 '13 at 17:00
    
Fixes it in 14.04 also. Thanks –  isaaclw Jul 22 at 20:18

I hit this same issue with 13.10 (Saucy). As ZeTo said, CCSM solved the issue for me. Here's what I had to do:

sudo apt-get install -y compizconfig-settings-manager

run ccsm

agree to the warning about it being an advanced tool

select Ubuntu Unity Plugin (right side in the Desktop section)

Uncheck "Enable Ubuntu Unity Plugin" (left side of the screen)

Click Back (left side of the screen)

select Ubuntu Unity Plugin (right side in the Desktop section)

Now, check "Enable Ubuntu Unity Plugin" (left side of the screen) note: you will receive an error message about conflicts, just click "ignore conflicts" and continue

Exit CCSM and now the dash behaves properly for me, comes up in foreground instead of background.

share|improve this answer

Use ccsm to change Unity bar behaviour

share|improve this answer
1  
Could you possibly elaborate a bit on your answer? This tersely, it's not very helpful I'm afraid. :\ –  Stefano Palazzo Sep 9 '11 at 15:21
    
There is no option to set the z-ndex of windows in there. Even though I changed some settings to see if the bashing of unity could reset the z-index, it still doesn't work. –  joar Sep 9 '11 at 15:22
    
installing ccsm allows to tweak several unity settings, maybe changing the unity bar behaviour (eg. always on top) can solve your problem. –  ZeTo Sep 9 '11 at 15:28
    
@ZeTo - Thank you, I know what ccsm does, although for me it does not provide an option to set the z-position of the launcher/dash. There probably does not even exist such an option since very few will ever want to have the launcher/dash behind anything. –  joar Sep 9 '11 at 16:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.