Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm searching for a way to prevent gwibber-service from starting, but I can find none under Oneiric.

For a start, I confirmed that "Start service at login" was still unchecked in Gwibber preferences (it is), but gwibber-service still starts automatically at each login. So, I cross-checked under "Startup Applications..." (there is no entry for Gwibber there), I searched to see if there's an upstart job for gwibber-service (there is none), and I looked for a gwibber-service script in /etc/X11/Xsession.d (there is none).

So, I'm out of ideas. Do you know how to prevent gwibber-service from starting, or do you know other places where to look?

For further context, I had the "Start service at login" option already unckecked before upgrading to Oneiric. It used to work under Natty, but it no longer does.

share|improve this question
    
There was a similar question once askubuntu.com/questions/9197/… –  falstaff Sep 9 '11 at 14:24
    
@falstaff The old question is irrelevant for at least two reasons: there is no longer a Gwibber entry under startup applications and I don't want to uninstall gwibber-service, just to disable it from automatically running. –  tawmas Sep 9 '11 at 14:33
    
@falstaff I see the reference to Oneiric has been removed from my question title. I updated the question body. –  tawmas Sep 9 '11 at 14:42

2 Answers 2

Maybe disabling using gconftool helps?

gconftool-2 --set /apps/gwibber/preferences/autostart --type bool false
share|improve this answer
    
I just checked: it is already disabled (and I believe it is the setting controlled by the checkbox in the preferences UI). –  tawmas Sep 9 '11 at 14:29
    
The question I posted above concludes that indicator-me package is using this service, so it might be a problem of that starting the service although disabled... –  falstaff Sep 9 '11 at 14:34
1  
There might be a problem with the condition from gconf, move the autostart file from /etc/xdg/autostart to another directory, e.g. sudo mv /etc/xdg/autostart/gwibber.desktop ~ –  falstaff Sep 9 '11 at 14:38
    
Didn't know about /etc/xdg/autostart... sigh... I see the file has a line reading AutostartCondition=GSettings org.gwibber.preferences autostart, but the setting is ignored anyway. I should probably file a bug, and I'll remove the desktop file as a workaround. Thanks. –  tawmas Sep 9 '11 at 15:45
    
thank you, will try that, to see if it helps - does it works the same way to disable BEAM service?!? –  user44790 Feb 3 '12 at 9:33

You can disable it by disabling it in Startup Applications. Before going to Startup Applications make sure you made visible hidden applications with this:

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/*.desktop

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.