Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed likewise open via apt-get on 11.04 server 32 bit and have sucessfully joined our domain. however when trying to login via putty using a domain account I cannot complete the authentication. auth.log looks like this:

Sep  9 10:00:45 alfocr sshd[1196]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=timwin7-pc.*****.co.uk
Sep  9 10:00:47 alfocr sshd[1191]: error: PAM: Authentication failure for illegal user *****.co.uk\\\\talexander from timwin7-pc.*****.co.uk
Sep  9 10:00:47 alfocr sshd[1191]: Failed keyboard-interactive/pam for invalid user *****.co.uk\\\\talexander from 10.168.**.** port 50145 ssh2
Sep  9 10:00:57 alfocr sshd[1198]: Accepted keyboard-interactive/pam for ocradmin from 10.168.**.** port 50160 ssh2
Sep  9 10:00:57 alfocr sshd[1198]: pam_unix(sshd:session): session opened for user ocradmin by (uid=0)

I am guessing that the extra \ characters are what is causing it to fail but I cannot work out where they are coming from. I have tried logging in with domain\username and domain\username but neither seems to work. Does anyone have any suggestions?

EDIT: Turns it that it is possible to login via the console (form the box itself). so it must be an isue with how putty is passing the commands. anyone come across something like this before?

share|improve this question

1 Answer 1

Somewhere I read that its also possible to use + instaed of the backslash with samba, don't know if this is also valid for likewise...

share|improve this answer
    
good suggestion, just tried it but with the same outcome. really starting to get to me this, its so close to be ready lol –  Tim Alexander Sep 9 '11 at 12:03
    
not really sure how it has all worked now but everything seems correct. full reinstall and deb packages from the likewise site rather than repository. just need to sort out samba now :) –  Tim Alexander Sep 26 '11 at 15:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.