Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I wiped out the password file in root folder with the cat command, I tried to restart the system, but no longer works.

What can or should I do? I learn well from mistakes, I have tried recovery mode but it also terminates on boot, please help.

share|improve this question
    
Which file did you delete, and why? – Wilf Apr 7 '15 at 18:37
1  
Please edit your question: Which file do you mean exactly? What happens when you start the recovery mode? You can take pictures and link in your question. – A.B. Apr 7 '15 at 18:40
    
I deleted the passwd file in the root directory by accident,in recovery mode i come across this error: Caught abort,core dump. Error while reading from file descriptor – Philip Chani Apr 7 '15 at 19:04
    
See if the /etc/passwd- file exists (with the previous version of the pasword file). You can get a list of all the users to recreate (but not UID & GID) from /etc/shadow – waltinator Apr 7 '15 at 19:41
    
See if the /etc/password~ exists. If it does, copy it to /etc/passwd. If not, restore /etc/passwd from your last back-up. – dn-ʞɔɐq ɹW Apr 11 '15 at 15:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.