Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In the TeX - LaTeX group of Stack Exchange, I posed a question about the versions of TeXLive under Ubuntu. As I have installed the latest version of TeXLive under Ubuntu, I want to be able to use it when running an integrated development environment like KILE. Though a solution (and fix) was presented on the KILE Support Discussion Group, it involves downloading, compiling and installing the latest version of KILE.

In order to compile KILE, I need:

  1. KDE Libraries 4.2 or better
  2. Qt 4.5 or better
  3. Cmake 2.6.2 or better
  4. A recent C++ compile, for example GCC 4.4

My problem is that I can't determine what version of the KDE libraries or Qt I have installed on my system. Note that I am running Ubuntu Version 11.04.

My question, however, is whether or not the latest version of KILE (Version 2.1) will be included in the next release of Ubuntu (i.e. Version 11.10). If so, I could save myself the effort and grief of compiling and installing KILE. If not, will my installing the latest version affect the Synaptic Package Manager's ability of applying any future releases/updates to KILE?

Any help/suggestions would be appreciated.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

According to the source page for kile, 11.04 shipped with 1:2.1.0~svn1112278beta4-2ubuntu2, and 1:2.1.0~svn2010122beta5-1ubuntu1~natty1 is available as a backport.

11.10 already appears to have 2.1.0 final.

This fellow appears to have a PPA of Kile 2.1 so that you don't have to compile it yourself:

https://launchpad.net/~kile/+archive/stable

You can find information on how to add and use PPAs here:

Here's a command line snippet on how to use it:

sudo add-apt-repository ppa:kile/stable
sudo apt-get update
sudo apt-get upgrade

Will upgrade your kile to that version (2.1). Ubuntu automatically disables PPAs the next time you upgrade your OS and usually you'll just pick up the newest version that is available at that time.

share|improve this answer
    
Thanks for that! I'll let you know how I go. –  Bill Sep 9 '11 at 0:16
    
It worked! Once again, thank you for your help! As a matter of course, I will report this solution back to the TeX - LaTeX group under the Stack Exchange. BTW - Correct me if I am wrong but, would PPA be similar to Darwin Ports? –  Bill Sep 9 '11 at 0:32
    
Yep! I figured as much! Thanks! –  Bill Sep 9 '11 at 0:40
    
It seems that the ppa is not suitable for precide pangolin. Isn't it? –  Alessandro Cuttin May 21 '12 at 15:38
    
No, 2.1.0 is in 12.04 already. –  Jorge Castro May 21 '12 at 15:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.