Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I followed the question How do I replace the desktop by an application religiously and was very excited when it worked on my laptop. (Dev environment).

The next step for me was to replicate it on a touch screen kiosk (production environment) to prevent users to be able to log onto the OS.

I now have two environments with exactly the same files, permissions and folders on both: I even checked the /etc/gdm/custom.conf file. The only difference is that on the working envirenment file //usr/share/xsessions/Custom the line is :

Exec=/home/kiosk/.xsession

where on the other production kiosk the line is

Exec=/home/kioskoo/.xsession

Both matches the users on the systems.

The only difference between the two environments is that on the working version I have apache2 installed and no apache install on the one that does not work.

Weird, I know. Any ideas?

I have even pasted the text in a document to compare hoping I would find a difference. I can make that available too.

I need to make it work on the production kiosk ASAP, so any help/pointers/ideas will help!

**

Additional Information:

**

Sergey and Takkat, I do apologise for not making it clear.

Tthe specially created user, (kiosk00) supposed to open firefox without starting GNOME, is specified in the login screen with User Defined Session set as default session.

When I start the PC, the correct UID will be launched, but GNOME is started: It is as if the .xsession is not read ??

Files, Permissions and Text:

1)

drwxr-xr-x 6 root root 4096 2011-09-08 21:30 gdm

//etc/gdm/custom.conf -rw-r--r-- 1 root root

[daemon]

TimedLoginEnable=true

AutomaticLoginEnable=false

TimedLogin=kiosk00

AutomaticLogin=kiosk00

TimedLoginDelay=30

DefaultSession=xsession

2)

drwxr-xr-x 2 root root 4096 2011-09-08 21:46 xsessions

//usr/share/xsessions/Custom -rw-r--r-- 1 root root

[Desktop Entry]

Name=Custom

Comment=Custom Session to run ~./.xsession

Exec=/home/kiosk00/.xsession

X-Ubuntu-Gettext-Domain=gdm

3)

drwxr-xr-x 28 kiosk00 kiosk00 4096 2011-09-09 20:20 kiosk00

//home/kiosk00/.xsession -rwxr-xr-x 1 kiosk kiosk

#!/bin/bash --login

gnome-wm &

firefox

logout
share|improve this question
4  
You didn't told us what is not working :) Any errors? Anything in error logs? –  Sergey Sep 8 '11 at 23:53
1  
As we don't know what exactly does not run in your system we can only guess. Permissions? –  Takkat Sep 9 '11 at 6:11
    
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! –  Tachyons Apr 22 '12 at 3:23
add comment

closed as too localized by Luis Alvarado Mar 14 '13 at 15:30

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.