Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I don't know how, but somehow the Ctrl keys on my keyboard have messed up. Left Ctrl key is opening a help window and right Ctrl key prints the "x" character. I tried setting/re-setting keyboard shortcuts and rebooting the system but that didn't help.

Any suggestions?

share|improve this question

migrated from stackoverflow.com Sep 8 '11 at 12:22

This question came from our site for professional and enthusiast programmers.

closed as too localized by jrg Feb 27 '12 at 23:32

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Sounds like your keyboard has been re - mapped, try mapping it to the defaults, I know this can be done on windows but not sure about Ubuntu –  Bali C Sep 8 '11 at 11:36
    
i tried to restore it to defaults but not working. Nothing has been mapped in keyboard shortcuts as well. –  Rahul Sep 8 '11 at 11:40
    
I haven't used Ubuntu much but this might help - help.ubuntu.com/community/MultimediaKeys –  Bali C Sep 8 '11 at 11:42
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  jrg Feb 27 '12 at 23:32

1 Answer 1

You could try going to System Settings (in Unity, from the indicator menu on the top-right), then click Keyboard from Hardware section, and click button Restore default.

If it does not work, check the selected keyboard model, and check also the there is no strange flags in list appearing clicking on Options button.

share|improve this answer