Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Harmony 650 remote I am using for XBMC. I have it set up as a MCE remote in lirc using an HP ir usb receiver. When I run irw, not all of the keypresses are being picked up. I can see the red light flashing on the receiver, but nothing in irw. The only keys it is picking up are Channel Up, Channel Down, OK, 1, 2, and 3. I was considering using irrecord to create a custom lirc.conf file for the remote, but wanted to check if anyone had any ideas first.

share|improve this question
    
I guess I can't answer my own question for five more hours, but this should be marked solved. I figured out my problem. When setting up the remote based off of the original remote (which came brand new with the new IR receiver) the "new" batteries it came with were close to dead. Thus only some of the buttons mapped correctly. I noticed this when I tried the original remote in irw and it started out OK and suddenly quit returning keypresses. Fresh batteries and started from scratch = problem solved. –  Balthazar Sep 8 '11 at 5:20
add comment

1 Answer 1

I had a similar problem trying to get a remote working with MythTV on Natty. It seems that the kernel in Natty has IR remote capability built in and this should work with many types of IR remote. However, the problem is that the kernel maps some of the keys to keycodes greater than 256 and X can only handle keycodes in the range 0-255. I was eventually able to get my remote working by re-mapping the necessary keycodes to stay within this range. This is done using a utility called ir-keytable (in repository). It can also be used to track key presses instead of irw, which does not seem to work with the kernel driver.

Note that I did not need to install lirc to get this working.

Hope this points you in the right direction.

share|improve this answer
    
Thanks for the input. Unfortunately my problem was between the keyboard and chair. I did notice when messing around with irrecord that some buttons kept returning "keypress out of range" or some such errors. I'll bookmark ir-keytable for future reference. –  Balthazar Sep 8 '11 at 5:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.