Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have had this bug for a long a time and have been unable to research a solution. If not a solution, some ideas of what other methods I could take to determine the exact cause would be helpful.

Laptop: Dell lat 6520 running ubuntu 10.10, GNOME 2.32.0

The bug: every so often while I'm typing, a key will just keep "pressing" itself indefinitely. My keyboard is not dirty; the key is not physically stuck, this bug presented itself in the first week of use of this laptop. It can happen to any key, even the shift key ("enter" and arrow keys are especially annoying), and in any application, implying to me it may be hardware related. The rest of the keyboard is unresponsive; if I switch to another application, it continues there as well. I have still have use of my external mouse, and have found that I can put the box into Suspend, and restore it a few seconds later, it is gone.

However, after restoring from suspend, I always notice the first time I press the key that was stuck, it doesnt register; example: my password contains a letter "v". If "v" was the stuck letter, I have to press "v" twice to get it register the first time while logging in, then it works fine afterwards.

So today, I attached xev to my Geany application since thats where I work most of my time and waited for it to happen as it always does. The lucky key this time was "=".

Here is a snippet of the xev log file: http://pastebin.com/pS8RDxgr

You can imagine how annoying this random crap is. Any clues or helpful suggestions are greatly appreciated. If you know if any other logs you'd like to see from that time, or something else you think I should run while waiting for it to happen again, I gladly will.

Here are some things I've tried:

  • Still searching around other issues that sound somewhat similar, I read several suggestions that setting the boot option acpi=off will solve many kinds of input related issues or crashes.

  • Setting acpi=off ^ did not work. The bug still exists.

  • I installed xdotool which allows you send key events to X or a specific window, wrote a script to send a KeyUp event for every key I can possibly type on this laptop keyboard, and put it on my toolbar. So hopefully next time it happens, I can click to run it and it will catch a keyup event for whatever key is stuck that time.

    I am hopeful, because I noticed after playing with xdotool, that it reproduces the same effect the bug does after I suspend - the key doesnt register the first time you press it. If I use 'xdotool keydown x', it just sends 'x' like youre typing it, but after you kill it, the first time you press 'x', it doesnt register, just like my bug.

  • xdotool worked, somewhat. It stopped the constant keydown events (on the 'e' key this time), but afterwards the keyboard was unresponsive, just like when the keydown events were happening. I also have scripts to disable and re-enable the keyboard with xinput, which I tried, but they did nothing. I had to suspend my laptop and log in again to get the keyboard back.

share|improve this question

closed as too localized by fossfreedom Mar 12 '13 at 22:01

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! –  coversnail Apr 9 '12 at 17:06
    
This is not an answer unfortunately. A helpful user on the ubuntu forums gave me a list of similar posts from launchpad here: ubuntuforums.org/showthread.php?t=1846801 . From what I recall, it was related to the PS2 keyboard, but different manufacturers made it inconsistent, and apparently few people care about Maverick anymore anyway! I still haven't upgraded away from 10.10 yet, but that is the only potential solution I found. I did discover xdotool from this though, which is a handy utility. –  aparker Apr 11 '12 at 4:19
    
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! –  Eric Carvalho Mar 12 '13 at 19:54

Browse other questions tagged or ask your own question.