Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have

$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1f:d0:99:ea:a9  
          inet addr:192.168.1.130  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::21f:d0ff:fe99:eaa9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:309399 errors:0 dropped:0 overruns:0 frame:0
          TX packets:262110 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:312968243 (312.9 MB)  TX bytes:35445808 (35.4 MB)
          Interrupt:44 

lo        Link encap:Локальная петля (Loopback)  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4175 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4175 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:975196 (975.1 KB)  TX bytes:975196 (975.1 KB)

But:

$ cat /etc/network/interfaces 
auto lo
iface lo inet loopback

How ifconfig show me settings for eth0? Where are settings store?

UPD: I do not use NetworkManager, and I have LXDE, not Gnome

share|improve this question
add comment

4 Answers

up vote 0 down vote accepted

This is most certainly the NetworkManager which is started after login, not at boot time. Look for the Network icon on the Desktop.

share|improve this answer
    
~/.gconf/system/networking/connections –  Thomas Sep 8 '11 at 10:09
    
Is is possible that NetworkManager is been used without the GUI. Configuratin files for this shoud be here: ~/.gconf/system/networking/connectionsor here: /etc/NetworkManager/system-connections. There are alternatives to NetworkManager tha could be in use, e.g. wicd (help.ubuntu.com/community/WICD). In the end there are several ways to set up a nework interface without using /etc/network/interfaces - as this is obviously a non-standard installation it's more like guessing. –  Thomas Sep 8 '11 at 10:15
    
It's true! [802-3-ethernet] duplex=full mac-address=0:1f:d0:99:ea:a9 [connection] id=Auto eth0 uuid=62a54eb7-a80e-497d-b764-c47a2aeb0ef5 type=802-3-ethernet timestamp=1310648604 [ipv6] method=ignore [ipv4] method=manual dns=192.168.1.203; addresses1=192.168.1.130;24;192.168.1.254; –  Guy Fawkes Sep 8 '11 at 11:30
add comment

You want to look at /etc/dhcp/dhclient.conf

In mine I get all settings from the DHCP server (on my router) apart from my hostname.

Relevant section

send host-name "<hostname>";
#send dhcp-client-identifier 1:0:a0:24:ab:fb:9c;
#send dhcp-lease-time 3600;
#supersede domain-name "fugue.com home.vix.com";
#prepend domain-name-servers 127.0.0.1;
request subnet-mask, broadcast-address, time-offset, routers,
    domain-name, domain-name-servers, domain-search, host-name,
    netbios-name-servers, netbios-scope, interface-mtu,
    rfc3442-classless-static-routes, ntp-servers;
#require subnet-mask, domain-name-servers;
share|improve this answer
    
I suspect this is irrelevant. I have almost the same content (in /etc/dhcp3/dhclient.conf), but the IP address is static, as configured in NetworkManager. –  enzotib Sep 7 '11 at 13:22
    
Yes, I always have 192.168.1.130, but there are a lot of computers in the network; I think it's impossible always get this IP. –  Guy Fawkes Sep 8 '11 at 8:36
    
No it isn't impossible, you get a lease time on the dhcp server (probably your router), assuming you connect more often that the lease time you will always get the same IP. That is by design. –  Richard Holloway Sep 9 '11 at 15:16
add comment

I suppose you are using NetworkManager.

That settings are managed by NetworkManager by default, that probably is setup to request values from a DHCP server.

Look for "Auto eth0" connection in NetworkManager.

share|improve this answer
add comment

AFAIK If you are using network-manager, interfaces are handled by network-manager

share|improve this answer
    
No, I don't use network-manager –  Guy Fawkes Sep 8 '11 at 8:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.