Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For some reason I'm plagued by especially rare bugs. This time my middle mouse button ceased to work in firefox exclusively. I can use it to copy stuff in terminal or to start another instance of a program clicking on the program's icon on the unity launcher bar.

But I can't use my middle mouse button to open a link in a new tab. That's quite annoying. The button click gets recognized, as the links highlight as I middle click them. A new tab just isn't opened.

I already disabled all addons to firefox to see if it's an addon problem. Turns out it's not. Even purging firefox and reinstalling didn't help.

I own a Logitec MX510 mouse on my HP laptop that also has Synaptics TouchPad. On the touchpad the middle and left button never worked in ubuntu at all (firefox or anywhare else).

Any ideas what could be wrong? What else could I try.

Edit:
Now the problem has reached my work PC as well. After the latest firefox-update (to version 6.0.2): The right mouse button on my work PC (Desktop) does open the context menu, but as soon as I move my mouse even the tiniest bit, the menu closes. So the problems might be related to the 6.0.2 update of firefox or not, but it's certainly suspicious that both PC have mouse problems ins firefox only.

share|improve this question

4 Answers 4

up vote 2 down vote accepted

Purging Firefox removes global settings only, not the Firefox profile itself. To check whether it's an issue related to your Firefox profile settings, try creating a new, clean one:

mkdir /tmp/firefox-test
firefox -profile /tmp/firefox-test -no-remote &

/tmp/firefox-test can be removed afterwards. If the problem is persistent, you might want to take a look at your settings in the about:config URL, search for keywords like "mouse", "click" and "tab". Otherwise, you could check the prefs.js file in your Firefox profile folder which is located at ~/.mozilla/firefox/XXXXXXX.PROFILENAME/prefs.js. If you can't get any out of it, quit the Firefox instance using this profile folder and rename / remove this prefs.js file to reset your settings. If this still does not help, export data like your bookmarks and create a new profile using the Profile Manager which can be started with firefox -p.

share|improve this answer

Here's the fix:

  1. Install gpointing-device-settings

    sudo apt-get install gpointing-device-settings
    
  2. Then run

    gpointing-device-settings
    

    Click the genius optical mouse option, and check the 'use middle button emulation'

share|improve this answer

go to 0.9.11 (update to the current 0.9.10, fixing the tabmixplus - greasemonkey snafu of 0.9.10 -- strangely I stumbled upon this error only with todays firefox 7 update from the ppa...)

https://addons.mozilla.org/en-US/firefox/addon/greasemonkey/versions/?page=1#version-0.9.11

share|improve this answer
    
The OP writes that the problem remains with addons disabled. –  N.N. Sep 7 '11 at 9:22

solution is here: http://superuser.com/questions/332782/middle-click-tab-opening-stopped-working-in-firefox/332794#332794

I simply uninstalled Greasemonkey, which I did not use anyway.

share|improve this answer
    
The OP writes that the problem remains with addons disabled. –  N.N. Sep 7 '11 at 9:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.