Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have had problems connecting with ssh through the terminal to different machines around my workplace and my home.

The three last lines is (if I run ssh with -vvv):

debug3: load_hostkeys: loaded 0 keys
debug1: SSH2_MSG_KEXINIT sent
Read from socket failed: Connection reset by peer

There is no problem with the network, because putty works perfectly with the exact same server. Also, if I sit down with my colleagues machine (also ubuntu, same version as mine, 11.04), it works like a charm from the terminal.

I have tried to delete my .ssh . So I guess something else is wrong, anything I can do to uninstall and reinstall or delete to reset this?

EDIT: I found a duplicate:

share|improve this question

My own question was answered on the duplicate question on serverfault (first answer). I added:


to ~/.ssh/config

share|improve this answer

The behavior of the ssh-client is also influenced by /etc/ssh/ssh_config. Maybe you edited it somehow?

share|improve this answer
Thanks, but the change dates on those files are way old. – Gunslinger Sep 9 '11 at 10:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.