Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I first installed Ubuntu 11.04 I marked NOT to ask password in login. Then, ofcourse, it didn't ask me password on login. But now I want the OS to ask login password as I have many critical datas stored. I changed the settings to Password: Asked in Login but it doesn't work. My Ubuntu doesn't ask password in login. What should I do now?

share|improve this question

3 Answers 3

Go to

System Setting -> System -> Login Screen -> Unlock

You will need to enter your password.

Then select the option that says "Show the screen for choosing who will log in"

share|improve this answer
1  
This one helped. Thanks! –  Bibek Karki Sep 7 '11 at 15:11
    
@Bibek Karki: If this answer was helpful to you, then please consider marking it as the accepted answer so others may more easily find it in the future. This is also a polite way to thank the person answering your question for helping you out. –  Danatela Mar 11 at 6:23

I had same problem. Try running this command:

sudo gpasswd -d $USER nopasswdlogin 

this should work.

The thing is that my user was in the nopasswdlogin group. I had to install the gnome-system-tools which has the GUI to manage users and groups. Then I ran the users-groups manager and change my user to NOT be part of the nopasswdlogin group. Problem Solved.

share|improve this answer

This tutorial explains How to disable password prompts in Ubuntu. In case if you want to enable password prompts, try to do that vice versa

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.