Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to install the Unity 3-d web player on Ubuntu 11.04. I would like to use it on different sites such as http://firecraft.games2be.com/play. Is it possible?

share|improve this question
add comment

6 Answers

Their website says the plugin is only available for Windows and MacOS X:

Unity Web Player

The Unity Web Player is not currently compatible with the operating system that you appear to be using.

Unity Web Player for Windows Internet Explorer, Firefox, Chrome, Safari, Opera

Requirements: Windows XP/Vista/7

Unity Web Player for Mac OS X Safari, Firefox, Chrome

Requirements: Mac OS X 10.5 or newer

Your best option would be to install Windows in a VirtualBox and use it to view those sites.

share|improve this answer
add comment

The player you said doesn't seem to support Linux as of yet. It would be really hard to get this working and not worth your time.

Did you try using the Internet Explorer that ships with Wine? Try installing the latest version of Internet Explorer on Wine and see if that plugin installs in that browser. Download it first, put it in that virtual C drive and keep doing something until it works/ breaks.

If that doesn't seem to work, you may try VirtualBox like Sergey suggested, but i think it would be useless to play games in VirtualBox.

Something not related to question: If you want to watch some videos in 3D then try Bino player. It enables you to watch videos in 3D... So, if you wanted to watch a video in 3D, you can use it.

Or may be you can record your browser screen and later watch it in 3D, but that just sounds crazy. There are some players like this in software center, so check out if any of them helps you in watching your browser in 3D. May be you can try your luck with Firefox addons too.

share|improve this answer
add comment

Unity 4 will introduce Linux support, according to their website. Unfortunately, it will be a few months before that is released.

You can check out their webpage here. You can use CTRL F to launch the find utility, then type in "linux" to scroll down to that section

share|improve this answer
    
This is great info. Is the beta version out? –  213441265152351 Jun 29 '12 at 8:55
1  
It will probably be shown off at the Unite 2012 Developer Conference in August, and then will probably be released a few months later. Reports have said later 2012/early 2013 –  Compt Jun 29 '12 at 13:22
1  
This still does not include Linux support for the Web Player - at this time anyway. –  Oli Apr 26 '13 at 11:07
add comment

The nearest result we had with unity web player is to install Firefox on Wine 1.4 and try to load Unity web player.

it will start loading the unity plugin with failed at updating it and then running it.

Sorry there is no solution with Wine currently (which is a shame)

I'm happy to see that they will support Linux in next version.

then the best way for you is to use XP in VirtualBox with 3D acceleration.

share|improve this answer
add comment

They are about to launch the Unity4 preview which will provide a Linux client. I think it will be available during the summer. The best thing to do is probably to pre-order the new version just here : http://unity3d.com/?unity4

Maybe you will have a beta access :)

share|improve this answer
add comment

This is what I would do

Mind you, this MIGHT NOT work but it shouldn't break anything. This is my technique for getting weird crap to work in wine.

  1. Install wine
  2. Install winetricks
  3. Match runtimes/applications required in winetricks (search net for exact requirements IE: needs Directx10.x or dotnet framework, fonts? etc...)
    • install direct3D, geko, etc...
    • Might wanna install Windows version Firefox or chrome under wine
    • Do a search for any other dependencies the program needs.
  4. Attempt to install Unity 3D player in wine.
  5. If failure, then: Review error for any "not found" or "error in/on _ _ _ _ _ and search the term for any "This happens when you dont have _ _ _ _ installed" or "needs _ _ _ libraries"
  6. Repeat

    Hope it helps.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.