Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed gnome from a kubuntu 11.04 installation using apt-get

$ apt-get install gnome-desktop-environment

Everything was working just fine until I decided to change the panel format. Then a tried to fix it following both those instructions, with no success:

How do I reset GNOME to the defaults?

How do I reset my Unity configuration?

Nothing is working inside Gnome now, not even ALT+F2 I tried to uninstall and install it again, and I tried to install Unity too.

Any ideas in how to solve this issue?

share|improve this question
    
Does the problem affect all users or just one? –  Pavel S. Sep 6 '11 at 21:52

1 Answer 1

As suggested in the first question you're linking to, removing Gnome directories from your home directory should definitely reset it to its default settings.

Can you double-check that the following folders in your home folder are indeed being deleted:

.gnome .gnome2 .gconf .gconfd .metacity

The most bullet-proof way to do this is to log out, switch to a terminal with Alt-Ctrl-F1, log in with your normal username and invoke

cd $HOME
ls -la # see if the folders exist at this point
rm -rf .gnome .gnome2 .gconf .gconfd .metacity
ls -la # confirm that the folders no longer exist
sudo reboot # just to be sure

If you can confirm that the directories are deleted and this doesn't fix the problem, then the problem is not related to your changes to the panel - most likely something you installed after you installed Gnome prevents it from working (Unity?)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.