Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Open-zwave lib link: http://code.google.com/p/open-zwave/source/browse/

Toolchain used: http://code.google.com/p/wl500g/downloads/list?can=3&q=hndtools-mipsel-uclibc-4.4.6-K26

Asus RT-N16 running on wl500g firmware: http://code.google.com/p/wl500g/

I've tried to do the following:

  1. added toolchain path: PATH=$PATH:/home/user/hndtools-mipsel-uclibc-4.4.6-K26/bin/
  2. сhecked out all needed files: svn checkout http://open-zwave.googlecode.com/svn/trunk/ open-zwave
  3. added CROSS_COMPILE = mipsel-linux- to /open-zwave/cpp/build/linux/Makefile
  4. tried to make: ~/open-zwave/cpp/build/linux$ make
  5. got error: ../../hidapi/linux/hid.c:40:26: error: linux/hidraw.h: No such file or directory
  6. replaced gcc with mipsel-linux-gcc, g++ with mipsel-linux-g++ at /home/user/open-zwave/cpp/hidapi/linux/Makefile
  7. tried to make HIDAPI: ~/open-zwave/cpp/hidapi/linux$ make
  8. got another error: hid-libusb.c:44:19: error: iconv.h: No such file or directory

How to cross-compile that?

share|improve this question

closed as too localized by fossfreedom Mar 12 '13 at 22:09

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! –  Eric Carvalho Mar 12 '13 at 19:57