Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The file size is of 50 MB (OpenOffice file). While opening the file the system hangs completely.

Processor : Core 2 Duo

RAM : 1 GB

HDD : 250 GB

OS : Ubuntu 10.10

Note: I have tried LibreOffice too. I experience the same problem both in OpenOffice and in LibreOffice. Any other alternative way to open the file?

share|improve this question

closed as off topic by Marco Ceppi Feb 6 '12 at 20:44

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
can you open the file via a terminal? so if there is a error you can see it? To me it sounds like you are running out of RAM. do you have htop installed? if so you can monitor your RAM when you open the file. –  Alvar Sep 6 '11 at 18:20
    
1GB of ram is not enough to open a 80 MB file? LOL –  karthick87 Sep 10 '11 at 4:27
    
How much RAM is the system using? You don't have 1 GB RAM to open a 80 MB file. My Ubuntu system takes about 700 MB of my 1.7 GB RAM. Is the file damaged in any way? Are you able to opne it on another system/computer? :) –  Alvar Sep 10 '11 at 5:06
    
If you don't want to use htop, you could use this systemindicator instead. It uses some RAM, but it's easy to see how much RAM the system is using. askubuntu.com/questions/30334/list-of-application-indicators/… –  Alvar Sep 10 '11 at 5:59
    
It is opening fine in Microsoft Office but not in open office.. –  karthick87 Sep 10 '11 at 9:53

2 Answers 2

up vote 2 down vote accepted

There are a couple of programs that can open odf files, at least KofficeInstall Koffice and AbiwordInstall Koffice should be able to open it.

You can also try to open it with Google Docs and save it again.

Anyway, you should open a bug in OpenOffice and attach the file there if it's possible (i.e. it's not confidential or personal).

share|improve this answer
    
It should be better to file the bug in LibreOffice’s bug tracker. Seems that OOo’s development is almost dead. –  Fitoschido Sep 7 '11 at 1:01

wow! how did you get a libreoffice file so massive?! a 100,000 word book is only about 200kb. try alternate text editors such as gedit, koffice, abiword etc. if none of them open it then there's a problem with the file, not the office suite. also try opening it with libreoffice again. the afforementioned book crashed it twice, then it worked the third time.

by the way, Libreoffice and Openoffice are pretty much identical at this point of Libre's development. it has only just split from Openoffice and Oracle.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.