Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Main Problem

I am unable to connect to the internet from Ubuntu 11.10.

Additional Info

I am trying to connect using a 3G USB modem via a mobile broadband connection.

Country: South Africa

Provider: Cell C

Before upgrading to 11.10, the same internet connection worked flawlessly in Ubuntu 11.04, but presented the same problem in Ubuntu 10.10.

Additional Reading

What Happened?

So I decided to be brave and upgrade Natty to 11.10 Beta.

The Upgrade manager read the package lists, fetched new packages and then installed the upgrades completely before abruptly stopping and saying that the upgrade has been aborted. I clicked OK and then a new box showed up saying that the upgrade has completed, but with some errors.

So I restarted my computer. Greeted by the Lightdm screen, I logged in as usual. I received an annoying error saying that a system program has encountered an error. After searching Google, I found a solution that fixed that. Then I had nautilus errors where Nautilus had encountered errors and was forced to close.

I also had an error saying that the modem manager has encountered an error and has closed. After trying dpkg --configure commands I figured from the error message that 2 packages were missing. One was libatk-adaptor and the other was some python package. I could not connect to the internet all the while so I loaded the live CD of 11.04, downloaded the packages, rebooted Ubuntu, installed those packages and whoop whoop! No more errors.

However I still cannot connect to the internet! My 3G USB modem is recognized, I set up the connection as usual and then click on the network indicator, select my connection, the indicator flashes for a while before displaying a notification that the network is disconnected.

So what have I tried?

I tried using my phone as a modem (worked well in 11.04). --> Same error.

I downloaded the modem manager 0.5 using the live cd and then rebooted in Ubuntu, uninstalled the modem manager and then reinstalled it, --> still the same problem.

My Plea

So basically without internet my Ubuntu system is dead. What's interesting is that with the final release of Ubuntu 10.10 I have exact same problem. I get the same problem when trying to connect to the internet. It seems only Natty works in connecting to the internet. Now I'm a fairly new Ubuntu user. Started using Ubuntu in April this year when Natty was released so I don't know that much. What do I do? How can I get to connect to the internet using Oneiric?

share|improve this question
    
And it is Oneiric. –  Rinzwind Sep 6 '11 at 14:02
1  
I'm sorry that Oneric doesn't work for you. This site is not the best place to solve your problem, you should file a bug (askubuntu.com/questions/5121/how-do-i-report-a-bug) to get the problem sorted for everybody before release. Please don't forget to add basic info like the model of USB modem that you are using. –  Javier Rivera Sep 6 '11 at 15:31
    
Welcome to Ask Ubuntu! We're not the best place for answering questions about alpha/beta releases, please see: I am using an Alpha/Beta release, what should I do? –  Jorge Castro Sep 10 '11 at 16:25
    
Thanks Jorge I will try to file a bug :) –  MSayanvala Sep 16 '11 at 10:12
    
@JorgeCastro It's not a localized problem, I'm not able to connect my mobile broadband device in India. It used to work perfectly in 11.04, what has changed? –  avi Oct 16 '11 at 12:34
show 3 more comments

closed as too localized by Javier Rivera, Lekensteyn, Jorge Castro, jrg, Marco Ceppi Sep 10 '11 at 18:47

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.