Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using a Laptop Lenovo x121e (AMD-Version). The laptop has a Synaptics touchpad/trackpoint combination. The touchpad is very "jumpy" when trying to tap the pad for a mouse click.

Normal mouse movement is fine but when I try to tap the touchpad the pointer often moves away a few dots. Similar behaviour has been reported by windows-users of the x121e, here a solution is to install the latest driver from Synaptics. I haven't found a similar solution for Ubuntu (11.04, 64 bit).

share|improve this question
    
I am facing a similar issue. Can you tell me what you did to fix this? –  Christian Fazzini Jan 10 '13 at 15:18

1 Answer 1

up vote 0 down vote accepted

Hi I faced the same problem today with my x121e and arch linux.

The solution was to install the synaptics-driver (for me xf86-input-synaptics) and edit an xorg-configfile.

Here is a discription of the problem with the tipp to use the synaptics-driver: http://thinkpad-forum.de/threads/120560-X121e-Touchpad-Ultranav-macht-%C3%84rger-...

And here is the discription for my distribution (page is in german) https://wiki.archlinux.de/title/Synaptics_Touchpad_Treiber

share|improve this answer
    
Ubuntu does use the xf86-input-synaptics driver, but in an older version (1.3) than arch linux. In arch linux there are versions 1.4 (in stable) and 1.5 (in testing). Not wanting to compile the driver myself I just tried to use the binary form the arch linux packages. The 1.5 version is not working, the older 1.4 is working (just replaces the .so file). 1.4 is much better than Ubuntu's 1.3, but still not perfect. In the end we can just wait for the current version showing up in Ubuntu and until that use the trackpoint. –  Thomas Sep 8 '11 at 15:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.