Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using a macbook pro and I recently upgraded to the 11.10 beta. Suspend no longer works. When I close the laptop lid, I can tell the screen turns off momentarily, but then comes back on. When I open the lid, it's at the unlock screen. The same things happens if I select suspend from the power menu.

What can I do to troubleshoot or fix this? I realize that I'm using beta software, but I'm not sure where to get started working on something like this.

share|improve this question

closed as too localized by Luis Alvarado Mar 14 '13 at 15:31

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

do you have enough swap in relationship with ram on your computer? Or it might be that some device is failing to suspend. Try to run:

 echo 1 > /sys/power/pm_trace

as root then after the failed suspend run dmesg "hash matches" you the last device on the list is probably the one failing to suspend for you.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.