Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Running Ubuntu 11.04. Got a bamboo Touch&Pen CTH-460 and it works out of the box. The pen response works great but the finger response is horrible. Is there a way to disable the finger response and only have the pen work? The tablet clearly differentiates between the two, so there should be a way to disable one. any thoughts?

share|improve this question

4 Answers 4

up vote 3 down vote accepted

Found my solution.

Edit /usr/share/X11/xorg.conf.d/50-wacom.conf and add "Option "Touch" "off"" to each group. Works like a charm.

share|improve this answer
    
If this is the best answer you should accept it even if it's your own. –  N.N. Sep 6 '11 at 7:00

You could use the command line utility xinput. First use xinput list to find your device id:

user@ubuntu:~$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB Trackball                    id=10   [slave  pointer  (2)]
⎜   ↳ Wacom ISDv4 E3 Finger                     id=11   [slave  pointer  (2)]
⎜   ↳ Wacom ISDv4 E3 Pen                        id=12   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=15   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ HP Webcam                                 id=13   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=14   [slave  keyboard (3)]
    ↳ HP WMI hotkeys                            id=16   [slave  keyboard (3)]

So in my case, the touch part has device id equal to 11. Next, you set the device enabled property use xinput set-prop, like this:

user@ubuntu:~$ xinput set-prop 11 "Device Enabled" "0"

You can enable it again with:

user@ubuntu:~$ xinput set-prop 11 "Device Enabled" "1"

You'll have to do this every time you restart your computer. Also, the device id may change between boots.

share|improve this answer

http://ubuntuforums.org/showpost.php?p=9496609&postcount=1

There you'll find a script to disable/enable the touch AND a patch to fix the touch problem. Worked perfectly with mine.

share|improve this answer

You can also use xsetwacom, which I think is a proxy for xinput, but for wacom/touch devices only. The id numbers in xsetwacom --list devices match up to xinput list.

Well, here's how to use xsetwacom:

this@this:~$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Wacom ISDv4 E6 Pen stylus                 id=10   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=13   [slave  pointer  (2)]
⎜   ↳ Wacom ISDv4 E6 Pen eraser                 id=15   [slave  pointer  (2)]
⎜   ↳ TPPS/2 IBM TrackPoint                     id=16   [slave  pointer  (2)]
⎜   ↳ Wacom ISDv4 E6 Finger touch               id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ Integrated Camera                         id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                    id=14   [slave  keyboard (3)]
this@this:~$ xsetwacom --list devices
Wacom ISDv4 E6 Pen stylus           id: 10  type: STYLUS    
Wacom ISDv4 E6 Pen eraser           id: 15  type: ERASER    
Wacom ISDv4 E6 Finger touch         id: 11  type: TOUCH     
this@this:~$ xsetwacom set 11 Touch "off"
this@this:~$ 
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.