Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am proficient with Windows and not so much with Linux. Here is my story:

Original system came with Windows 7, got openSUSE installed on the second hard drive, and dual boot for this setup worked fine. Wanted to switch to Windows 7 and Ubuntu 11.04 dual boot so I did a Windows system recovery and it appeared to give me back a fresh Windows 7 install.

I then go to install Ubuntu 11.04 and the installer informs me I have multiple operating systems already installed. I go to the advanced partitioning option and sure enough Windows 7 is on /sda while openSUSE is still on /sdb. From here I followed this guide (How to dual-boot Linux and Ubuntu with two hard drives) after I had deleted all the openSUSE partitions on /sdb through the Allocate Drive Space tab of the installer. I make the /boot, swap, /, and /home partitions and set the GRUB into the MBR of the second disk (/dev/sdb). Everything installs fine.

I reboot, Windows loads automatically, install EasyBCD and add an entry for Ubuntu into the Windows Boot Manager while assigning the type as GRUB2. Reboot the system and it now shows dual booting options for both Windows and Ubuntu.

Problem is: while I can use Ubuntu fine when I try to boot into Windows it just gives me a black screen and after a little while the fans start running crazy. If I restart the computer I will sometimes get the message that my system was put into hibernation mode because the temperature got too high (90C) which I presume is in accordance with the fans going crazy. I have linked the output from the Boot Info Script below, any suggestions on how to fix this issue would be greatly appreciated!

UPDATED SCRIPT OUTPUT Boot Info Script output:

share|improve this question
Hi, I've replaced the boot info script output with a link to Ubuntu's paste service. Unfortunately it seems like the info is incomplete (see link). Could you please run the script again and directly use to get a link and just edit your question? Thanks. – htorque Sep 4 '11 at 22:02
Script output should now be showing correctly. – Sean Sep 4 '11 at 22:10

The black screen resulting while booting into Windows 7 (dual boot setup with Ubuntu 11.04) appears to have come from using the newest Nvidia Drivers for my 230m card. Chose a Windows 7 restore point before the latest Nvidia drivers were installed and everything works in both WIndows 7 and Ubuntu 11.04. Although, I am getting an odd message almost every time I boot up that my machine was put into hibernation mode because the temperature was getting too high.


share|improve this answer
please, mark your answer as correct – Gerep Feb 24 '12 at 0:02

Looking over this table from your previous configuration I will assume a couple of things

Device           UUID                                   TYPE       LABEL

/dev/sda1        783A75E63A75A234                       ntfs       SYSTEM
/dev/sda2        A2D0756FD0754A95                       ntfs       OS
/dev/sda3        303619B436197BD2                       ntfs       RECOVERY
/dev/sda4        80E4-8C77                              vfat       HP_TOOLS
/dev/sdb1        354285b2-04d6-4eca-8282-f234302b5833   ext2       
/dev/sdb2        c720ad52-4d12-43a1-aa92-62e258caa03d   swap       
/dev/sdb5        16779e10-819b-4215-a767-b9e7e19e54bd   ext4       
/dev/sdb6        20d15c22-1eea-4680-aac5-83f0a0eda59d   ext4 

I'm a bit confused here. Over your first HD (sda) you have 2 different windows entry. One for "SYSTEM" and another for "OS". That might make a lots of difference for booting them. The thing is that it will be great to know if the win7 is at the "SYSTEM" or "OS".

If can still boot in ubuntu I recommend to try to fix your boot entries using this program called Grub-Customizer. To install it just type in a terminal:

sudo add-apt-repository ppa:danielrichter2007/grub-customizer

sudo apt-get update

sudo apt-get install grub-customizer

And run the program and it should pop up all the boot entries that it can find it, including the recovering win7 and the regular win7. At least for solved one problem that I had with installing a second ubuntu installation that messed up the menu entries. I hope it can help you out also.

share|improve this answer
there are quite a lot of entries but it says the Windows 7 (loader) is on /dev/sda1 while there are two Windows Recovery Environment (loader) on /dev/sda2 and /dev/sda3 – Sean Sep 4 '11 at 23:21
So there is your problem. Here at your Windows 7 (loader) there is the the uuid changed. At /dev/sda1 is 783A75E63A75A234 for "SYSTEM" and for /dev/sda2 is A2D0756FD0754A95 for "OS". Try to boot the first recovery option one and look for if the win7 boots. – fejao Sep 5 '11 at 0:39
after some digging it appears that the black screen of death during the Windows 7 boot was due to the latest and 'not-so-greatest' nvidia drivers that I had just installed prior to installing Ubuntu – Sean Sep 5 '11 at 5:12
So...did you manage to boot or not in win7? And if you fixed, could you please write your answer and mark as answered ;) – fejao Sep 5 '11 at 8:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.