Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running ubuntu 10.04. I have a newly purchased TATA Photon+ Internet connection which supports Windows and Mac. On the Internet I found a article saying that it could be configured on Linux. I followed the steps to install it on Ubuntu from this link. I am still not able to get online, and need some help.

Also, it is very slow, but I was told that I would see speeds up to 3.1MB.

I dont have wvdial installed and cannot install it from apt as I'm not connected to internet

Booting from windows I dowloaded "wvdial" .deb package and tried to install on ubuntu but it's ended with dependency problem. Automatically, don't know how, I got connected to internet only for once. Immediately I installed wvdial package after this I followed the tutorials(I could not browse and upload the files here) . From then it's showing that the device is connected in the network connections but no internet connection. Once I disable the device, it won't show as connected again and I'll have to restart my system. Sometimes the device itself not detected(wondering if there is any command to re-read the all devices).

output of wvdialconf /etc/wvdial.cof:

#wvdialconf /etc/wvdial.conf

Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Modem Port Scan<*1>: S1   S2   S3   
WvModem<*1>: Cannot get information for serial port.
ttyUSB0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyUSB0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 9600 baud
ttyUSB0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
WvModem<*1>: Cannot get information for serial port.
ttyUSB1<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyUSB1<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 9600 baud
ttyUSB1<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
WvModem<*1>: Cannot get information for serial port.
ttyUSB2<*1>: ATQ0 V1 E1 -- OK
ttyUSB2<*1>: ATQ0 V1 E1 Z -- OK
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyUSB2<*1>: Modem Identifier: ATI -- Manufacturer: +GMI: HUAWEI TECHNOLOGIES CO., LTD
ttyUSB2<*1>: Speed 9600: AT -- OK
ttyUSB2<*1>: Max speed is 9600; that should be safe.
ttyUSB2<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found a modem on /dev/ttyUSB2.
Modem configuration written to /etc/wvdial.conf.
ttyUSB2<Info>: Speed 9600; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"

output of wvdial:

#wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CRM=1
AT+CRM=1
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
CONNECT
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Sat Oct 16 15:30:47 2010
--> Pid of pppd: 5681
--> Using interface ppp0
--> pppd: (u;[08]@s;[08]`{;[08]
--> pppd: (u;[08]@s;[08]`{;[08]
--> pppd: (u;[08]@s;[08]`{;[08]
--> pppd: (u;[08]@s;[08]`{;[08]
--> pppd: (u;[08]@s;[08]`{;[08]
--> pppd: (u;[08]@s;[08]`{;[08]
--> local  IP address 14.96.147.104
--> pppd: (u;[08]@s;[08]`{;[08]
--> remote IP address 172.29.161.223
--> pppd: (u;[08]@s;[08]`{;[08]
--> primary   DNS address 121.40.152.90
--> pppd: (u;[08]@s;[08]`{;[08]
--> secondary DNS address 121.40.152.100  
--> pppd: (u;[08]@s;[08]`{;[08]

Output of log message /var/log/messages:

Oct 16 15:29:44 avyakta-desktop pppd[5119]: secondary DNS address 121.242.190.180
Oct 16 15:29:58 desktop pppd[5119]: Terminating on signal 15
Oct 16 15:29:58 desktop pppd[5119]: Connect time 0.3 minutes.
Oct 16 15:29:58 desktop pppd[5119]: Sent 0 bytes, received 177 bytes.
Oct 16 15:29:58 desktop pppd[5119]: Connection terminated.
Oct 16 15:30:47 desktop pppd[5681]: pppd 2.4.5 started by root, uid 0
Oct 16 15:30:47 desktop pppd[5681]: Using interface ppp0
Oct 16 15:30:47 desktop pppd[5681]: Connect: ppp0 <--> /dev/ttyUSB2
Oct 16 15:30:47 desktop pppd[5681]: CHAP authentication succeeded
Oct 16 15:30:47 desktop pppd[5681]: CHAP authentication succeeded
Oct 16 15:30:48 desktop pppd[5681]: local  IP address 14.96.147.104
Oct 16 15:30:48 desktop pppd[5681]: remote IP address 172.29.161.223
Oct 16 15:30:48 desktop pppd[5681]: primary   DNS address 121.40.152.90
Oct 16 15:30:48 desktop pppd[5681]: secondary DNS address 121.40.152.100

EDIT 1 :

I tried the following

sudo stop network-manager
sudo killall modem-manager

sudo /usr/sbin/modem-manager --debug > ~/mm.log 2>&1 &

sudo /usr/sbin/NetworkManager --no-daemon > ~/nm.log 2>&1 &

Output of mm.log:

#vim ~/mm.log:

** Message: Loaded plugin Option High-Speed

** Message: Loaded plugin Option

** Message: Loaded plugin Huawei

** Message: Loaded plugin Longcheer

** Message: Loaded plugin AnyData

** Message: Loaded plugin ZTE

** Message: Loaded plugin Ericsson MBM

** Message: Loaded plugin Sierra

** Message: Loaded plugin Generic

** Message: Loaded plugin Gobi

** Message: Loaded plugin Novatel

** Message: Loaded plugin Nokia

** Message: Loaded plugin MotoC

Output of nm.log:

#vim ~/nm.log:

NetworkManager: <info>  starting...

NetworkManager: <info>  modem-manager is now available

NetworkManager:    SCPlugin-Ifupdown: init!

NetworkManager:    SCPlugin-Ifupdown: update_system_hostname

NetworkManager:    SCPluginIfupdown: guessed connection type (eth0) = 802-3-ethernet

NetworkManager:    SCPlugin-Ifupdown: update_connection_setting_from_if_block:     

name:eth0, type:802-3-ethernet, id:Ifupdown (eth0), uuid: 681b428f-beaf-8932-dce4-678ed5bae28e

NetworkManager:    SCPlugin-Ifupdown: addresses count: 1

NetworkManager:    SCPlugin-Ifupdown: No dns-nameserver configured in /etc/network/interfaces

NetworkManager: nm-ifupdown-connection.c.119 - invalid connection read from /etc/network/interfaces: (1) addresses

NetworkManager:    SCPluginIfupdown: management mode: unmanaged

NetworkManager:    SCPlugin-Ifupdown: devices added (path: /sys/devices/pci0000:00/0000:00:14.4/0000:02:02.0/net/eth1, iface: eth1)

NetworkManager:    SCPlugin-Ifupdown: device added (path: /sys/devices/pci0000:00/0000:00:14.4/0000:02:02.0/net/eth1, iface: eth1): no ifupdown configuration found.

NetworkManager:    SCPlugin-Ifupdown: devices added (path: /sys/devices/virtual/net/lo, iface: lo)

@
share|improve this question
2  
It's been done here: vikashazrati.wordpress.com/2010/02/07/… –  Srirangan Oct 22 '10 at 15:14
add comment

4 Answers

up vote 2 down vote accepted

From How to configure TATA PHOTON+ EC1261 on UBUNTU 10.04 Lucid Lynx by Aamir Aarfi:

1.- follow this guide :

How to install Tata Photon+ on Ubuntu 10.04

STEP #1:

Plug-in your device and download two .deb files on your Ubuntu desktop.

usb-modeswitch-data_20100418-1_all.deb

usb-modeswitch_1.1.2-3_i386.deb

Download the above links or from the latest Debian repo listed below.

http://packages.debian.org/squeeze/i386/usb-modeswitch/download
http://packages.debian.org/squeeze/all/usb-modeswitch-data/download
http://packages.debian.org/squeeze/usb-modeswitch-data
http://packages.debian.org/squeeze/usb-modeswitch

STEP #2:

Installing required packages

  1. RIGHT CLICK on the package usb-modeswitch-data, SELECT "Open with GDebi Package Installer".
  2. If there is no error message then CLICK on "Install Package" button.
  3. RIGHT CLICK on the package usb-modeswitch, SELECT "Open with GDebi Package Installer".
  4. If there is an error regarding architecture then DOWNLOAD different package and repeat above step again.
  5. If there is no error message then CLICK on "Install Package" button.
  6. After this verify installation of these packages by following PART-I > Step1 with another debian version.

REBOOT your system [recommended]

STEP #3 [Important]

Modifying usb-modeswitch file

  1. OPEN Terminal again ("Applications" > "Accessories" > "Terminal")
  2. KEEP TATA Photon device connected, TYPE "lsusb" and you will get results like below. Bus 003 Device 002: ID 12d1:140b Huawei Technologies Co., Ltd.
  3. If your device shows no. different than 140b then use that in below steps.
  4. GO TO "/etc/usb_modeswitch.d/12d1:1446" and edit it. (GO TO parent most folder and then TYPE "CD /etc/usb_modeswitch.d/",
  5. TYPE "gedit 12d1:1446", the file will get opened in text editor.)
  6. ADD "140b" to the "targetList=" and SAVE the file.

Configuring Tata Photon+ as "Mobile Brodband" from Network Manager.

Step1 : GO TO "System" > "Preferences" > "Network Connections".

Step2 : CLICK on "Mobile Broadband" tab.

Step3 : CLICK on "ADD" button.

Step4 : Observe the device name below "Create a connection for this mobile broadband device". "HUAyWEI TECHNOLOGIES HUAWEI Mobile" should already be selected in drop down. If not SELECT it and CLICK on "FORWARD". NOTE:- If this device does not shows here that means your Ubuntu is still not treating this device as USB MODEM.

Step5 : SELECT country (e.g. India) from the list CLICK on "FORWARD".

Step6 : SELECT PROVIDER (e.g. Tata Indicom (Photon+)) from the list CLICK on "FORWARD".

Step7 : You will see "Your Device" and "Your Provider", CLICK "Apply" button.

Step8 : FILL following information under "Mobile Broadband" tab.

Number: #777
Username: internet
Password: internet

Optionally you can CHECK "Connect Automatically" option. CLICK on "Apply" button

Step9 : TYPE first user password and CLICK on "Authenticate". You will see "Tata Indicom (Photon+)" in Mobile Broadband connection list.

PART-III :- Starting "Mobile Broadband" Connection

Step1 : RIGHT CLICK on "Network Manager" icon on top-left corner of the screen.

Step2 : CHECK "Enable Mobile Broadband" option.

Step3 : Now CLICK on the same icon.

Step4 : CLICK on "Tata Indicom (photon+) connection1"

And THATS IT !!!!!!

2.-

another option is upgrade from 10.04 to 10.10 because THE DRIVER FOR TATA PHOTON+ IS PRE INSTALLED, so no need to install .deb file. Plug in your photon device and select the appropriate options from the Ubuntu network manager.

share|improve this answer
1  
This is also a great help. Thanks for your effort and interest. I followed the steps you suggested but some where it lacks something. But the thing you suggest to upgrade is sounds great!. I would like to mark your answer as accepted. Masters are always masters! –  user3215 Oct 24 '10 at 5:44
add comment

In fact, not much has to be done to use this dongle and you don't really need to install anything. You need to edit one file, though.

Press ALT+F2 and enter gksu gedit /etc/udev/rules.d/15-huawei-e161.rules to create the file we need. Now paste the content below into the file and save it.

SUBSYSTEM="usb"
SYSFS{idProduct}="1446"
SYSFS{idVendor}="12d1"
RUN+="/lib/udev/modem-modeswitch --vendor 0x12d1 --product 0x1446 --type option-zerocd"

Now just plug in your dongle and configure your connection using NetworkManager.

Explanation: The above file makes sure the command modem-modeswitch is run, whenever you plug in your dongle. The command itself just changes the dongle from cdrom-mode to modem-mode.

share|improve this answer
    
Well done master!. Thanks a lot for your great help! –  user3215 Oct 24 '10 at 5:39
    
what a simple technique! –  user3215 Oct 24 '10 at 5:45
    
This is the simple solution and I would like to recommend others to try 'mniess' answer first who are facing same problem. –  user3215 Oct 24 '10 at 12:29
    
you've any idea to reload to reload(scan/re-read) all devices like we do using task manager in windows?. –  user3215 Oct 24 '10 at 14:56
1  
Glad I could help. The speed you get should depend on your provider. I was able to get the maximum the chipset offers, when I was close to a cell-tower. If you want to reload the device, you'll have to re-plugin, I think. –  mniess Oct 28 '10 at 22:28
show 1 more comment

How did you test the speed if you were still not able to get online?

The steps in that link look correct, usb-modeswitch in Lucid is a little outdated and installing the version 1.1.4-1 from Debian usually fixes the problem. So, how many steps did you successfully go through? If all, you would probably want to open a bug on Launchpad and attach logs from NetworkManager and ModemManager.

As for the logs, there's a wiki page I updated on how to get them: http://wiki.ubuntu.com/DebuggingNetworkManager.

The trick is roughly to (in a terminal):

sudo stop network-manager
sudo killall modem-manager
sudo /usr/sbin/modem-manager --debug > ~/mm.log 2>&1 &
sudo /usr/sbin/NetworkManager --no-daemon > ~/nm.log 2>&1 &

Then reproduce the issue and attach both nm.log and mm.log from your home directory to the bug.

share|improve this answer
1  
Please point out how to find the logs! –  Jorge Castro Oct 11 '10 at 20:06
    
I checked it on windows os. On ubuntu all the steps were successful as followed the link. I'm searching log location. –  user3215 Oct 12 '10 at 1:15
    
updated with how to get the logs –  Mathieu Trudel-Lapierre Oct 14 '10 at 18:00
    
I've edited my question –  user3215 Oct 16 '10 at 11:15
1  
Ubuntu 10.10 can help a lot (it has more 3g modems working out-of-box) –  Extender Oct 22 '10 at 7:50
show 2 more comments

In Ubuntu 12.04.2, I just clicked on the network settings option (shown as one upward arrow and one downward arrow) on the top right corner of the screen and selected "Mobile Broadband". It gave me options to choose my country and select the provider. I chose it, and everything worked fine. If it still doesn't work, try doing the same thing after switching off the wired network in your network settings.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.