Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Oneiric Beta on my laptop. As my Mobile Broadband refused to connect to Internet through network manager I'm now using wvdial to connect. Hence the network manager shows I'm not connected to any networks. When I try to install software from Ubuntu Software Center the 'Install' option remains disabled and under reviews section it says no network connection! As a workaround I kept installing applications from terminal which works fine.

Therefore, my question is how to make Software Center recognize that I am connected to Internet?

share|improve this question

3 Answers 3

up vote 5 down vote accepted

You can't ... yet.

Please file a bug for both these issues: it's definitely an issue to not be able to override what NetworkManager tells Software Center, and it's also an issue that NetworkManager can't handle your Mobile Broadband connection.

As a workaround, if you're not using one of your connections, you could add dummy entries to /etc/network/interfaces to trick NetworkManager into thinking you're online. The way to do this:

auto eth0
iface eth0 manual

If you don't need to use your wired connection. Then reboot or restart NetworkManager. Of course this will break it for when you really need to use it :(

share|improve this answer
    
It's 2014....sadly the problem with network manager still persists.. :( –  pinkpanther Mar 9 at 18:20

Manually entering the connection settings solved my software center network detection problem.

Click on the network icon in your taskbar, go to Edit connections, edit your connection and under IPv4 designate a Manual method, and then add IPv4 address, network mask and default gateway

I understand this might not help mobile broadband users, but hey... worth a shot

share|improve this answer

The answer for this question, worked for me. The suggestion is to stop and start network-manager as follow:

sudo stop network-manager

and then

sudo start network-manager

This fixes the issue with Ubuntu Software Center not detecting you Internet connection.

share|improve this answer
    
can you mention your specification? Ubuntu version etc? –  Ade Malsasa Akbar Sep 28 at 5:25
    
@AdeMalsasaAkbar I believe I was using Ubuntu 10.04 back then. The command for 12.04 and above has changed to simply sudo service network-manager restart. –  tsega Oct 2 at 19:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.