Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

yesterday everything was fine and today when i logged on to my ubuntu 10.10 I noticed that the icons in the top of each menu dissapeared(I mean the the bar where the close mini maize etc..) this problem is not new for me in ubuntu 10.10 but it also happened in ubuntu 10.04 so please if somebody knows how to fix this post the answer

share|improve this question
1  
Could you include screenshots to exactly which icons you are referring too? As it stands this question is a little to vague to properly answer. –  Marco Ceppi Oct 11 '10 at 14:19
    
@Marco: "I mean the the bar where the close mini maize" sounds to me like he's talking about the titlebar/window decorations. I.e. the window manager fails to start for some reason. –  sepp2k Oct 11 '10 at 14:30
3  
If you run nohup metacity --replace & and then, if you have visual effects enabled in System -> Preferences -> Appearance -> Visual Effects, run nohup compiz --replace &, what is the content of ~/nohup.out (a text file)? –  ændrük Oct 11 '10 at 15:14
    
happens to me also pretty often. I have to restart to restore them. –  Elzo Valugi Oct 29 '10 at 6:56
add comment

6 Answers 6

Fixed it for now I hope it wont happened again.

I ended up running: metacity --replace in the terminal to replace the window decorations.

share|improve this answer
    
OK, but that command kills also all the special visual effects... –  Agmenor Jan 23 '11 at 21:05
add comment

If this problem appears more often, you will likely want to add metacity --replace to your startup commands.

share|improve this answer
    
I'm not sure why this was downvoted, I have compiz --replace in my startup commands to fix this same problem. –  Nick Pascucci Jan 23 '11 at 23:29
add comment

for better GUI application, try to install Compiz fusion Icon.

sudo apt-get install fusion-icon

if your metacity is not apear again, just run the application (Applications > System tools > Compiz fusion icon), the application's tray icon will appear and then right click the icon, choose reload window manager.

make sure you have selected 'compiz' in 'Select window manager' that tray icon menu.

share|improve this answer
add comment

Happened to me, too (some weird update?).... My solution was install latest NVIDIA drivers. That fixed the problem (wherever it was).

share|improve this answer
add comment

You could try this

gconftool-2 -s /desktop/gnome/session/required_components/windowmanager metacity --type string
share|improve this answer
add comment

I use Ubuntu 12.04.1 LTS with Gnome Classic. Today, after reboot, the window decorations disappeared. I was able to fix this by following these steps:

Open System > Preferences > CompizConfig Settings Manager; if it isn't installed, just run sudo apt-get install compizconfig-settings-manager in a terminal.

Once open, scroll down to the Effects section, where you will see Window Decoration is not enabled. Simply click the check box to the left of it, and you should see your window borders reappear.

For me the check box was still checked, but unchecking and re-checking made the decorations reappear.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.