Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since i'm still pretty green on hardware-setup in Ubuntu, i'd love some help on configuring my new HTPC.

I got an "old" 32" HD-Ready (1360x768) TV which i'd like to use as monitor. Problem is, this TV is not sending the correct data through HDMI. (EDID?)

I tried to manually configure X with different modelines, however i'm pretty sure I got the correct one now. My /etc/X11/xorg.conf looks like the following now:

Section "Screen"
    Identifier  "Default Screen"
    Monitor "Configured Monitor"
    Device  "Configured Video Device"
    DefaultDepth    24
    SubSection  "Display"
        Depth   24
        Modes   "1360x768"
    EndSubSection
EndSection

Section "Monitor"
        Identifier      "Configured Monitor"
        ModeLine "1360x768" 85.50 1360 1424 1536 1792 768 771 778 795 -Hsync -Vsync
EndSection

Is this the right way to configure X? Anyways, I tried restarting gdm but it doesn't change a thing.

I should probably mention, that most of the time my TV doesn't even display an image at all. When it does, its for a few seconds at a time, with lots of flickering and using just 2/3 of the screen width (with analog TV on the last bit). Setting different modelines and restarting X doesn't seem to make any difference.

I also tried logging in to the remote desktop, but I see that resolution doesn't change at all there. (.. which it does, if I put the HDMI in a PC monitor instead)

Any thoughts, and is this even the correct way to configure X these days?

share|improve this question
add comment

1 Answer 1

What video card do you have in that machine?

If you have an nvidia chip, this xorg configuration might work for you: http://pastebin.com/kFecUtju

share|improve this answer
    
Hmm I might not have mentioned it, but I use the I3 as GPU, i.e. no external video-card. I didn't have time to test the link you put yet, but I will shortly :-) I appreciate your answer. –  Tagger Sep 13 '11 at 7:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.