Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is a strange thing I've noticed across several different computers.

When I have a console session open, every time I scroll (say in a pager) there's a faint click for every line that goes by. It becomes more noticeable if I continuously scroll. Muting my laptop's speakers has no effect.

Is this by design, or some strange quirk?

share|improve this question
1  
Can you recall what models of laptops you've heard this on? I think I've noticed it too on my ThinkPad X60. Not sure if it's related, but my Sansa e270 also makes a faint "clicking" noise in my headphones whenever it updates its database. –  ændrük Sep 8 '11 at 22:28
    
My brother's EeePC netbook makes clicking sounds from time to time under both Ubuntu and Windows, where I'm guessing it's coming from the hard drive. It's entirely possible that it's normal mechanical noise you are hearing. –  WarriorIng64 Sep 9 '11 at 3:14
    
@ændrük Toshiba, HP, Sony and Mitek IIRC –  Matty Sep 11 '11 at 13:30
1  
Same for Thinkpad X201; when video is updated frequently (such as frequent redraws of a scene, paging down in firefox; though not for video, as that one is probably accelerated), I hear silent buzzing sound, as if the electrones in the wire were emitting sound ;-) It is not coming from the speaker either, sine it is hooked up to a stereo, which is totally silent. I never noticed it with any desktop computers, but with several laptops already (Thinkpad X61s was the same). –  eudoxos Sep 12 '11 at 7:17
1  
@Warrioring64: If I understand the description right, it is not hdd, which makes a distinctly different sound, a "mechanical" one, whereas what I had at least was "electrical" (wire interference). –  eudoxos Sep 12 '11 at 7:19

3 Answers 3

up vote 6 down vote accepted
+100

This is likely interference from the CPU power supply traces.

I particularly notice this in cases where there is a CPU governor that changes it's clock speed depending on load. The buzz you hear is actually the frequency at which the governor is changing CPU speed.

I recall an old laptop where the sound was not just audible in the 'phones, it actually manifested as a buzzing noise from the motherboard. For a while it was possible to suppress it by disabling SpeedStep and running the CPU at full clock speed all of the time, but eventually it was near constant, and I had to get the motherboard replaced for fear of losing my sanity.

These days I notice interference in my 'phones when the CPU load changes dynamically - when loading games in particular (bursts of CPU activity as it processes resources, followed by pauses as it waits for buffers to fill from the disk). It's more obvious when the headphones are plugged into the front panel of my desktop than the rear, which reinforces the idea that it's electrical interference ; the traces for the front panel are closer to the CPU, possibly. I plug my phones into the rear sockets which seem to be better shielded.

You might find that you get some relief by enabling the "spread spectrum" controls in your BIOS - these controls adjust the timings of internal system clocks to make the square edged waves less harsh and are designed to generate less interference. As noted in the article, spread spectrum is often disabled in overclocked systems to help prevent clock skew, but these features are usually enabled by default. You probably won't find these settings on a laptop BIOS though.

The other technique I use for combating this is to reduce amplifier levels. The alsamixer terminal application is useful here for finding all the relevant levels, some of which can be hidden in the GUI mixers. Dropping them all out of the red zone to about 80% means that the initial interference is amplified less and becomes inaudible. This also makes listening to music on my Windows laptop bearable - reduce the master volume to about 30%, rather than the Wave volume, and the interference disappears. This also reduces clipping on some hardware.

share|improve this answer
    
The CPU in the laptop in front of me that's exhibiting this behavior is a T3500, which doesn't support frequency scaling. The sound is definitely coming from directly from the motherboard (and definitely not from the HDD or regular speakers), so I'm not sure this is the answer. –  Matty Sep 11 '11 at 22:14
    
A change encounter with a comment on Slashdot says that googling "Intel C4 noise" is productive. See if you can disable the C4 power saving state in your BIOS and whether this helps with the noise - it seems to be a commonly enough encountered issue. –  Adrian Sep 14 '11 at 10:29
    
If this is the case, there may be nothing I can do about it with this laptop as there's no such option in the BIOS –  Matty Sep 14 '11 at 12:44
    
It's more obvious when the headphones are plugged into the front panel of my desktop than the rear: Yes, a thousand times yes! On every computer I've ever had. –  Ternary Jan 4 '13 at 0:01

Not sure since the internal speakers should be turned off by default but if this is the sound made by the internal speaker of your system you can turn this off with several methods.

  1. with

    xset b off
    xset b 0 0 0
    

    xset is a user preference utility for X. The b option controls bell volume (1st 0), pitch (2nd 0) and duration (3rd 0) in milliseconds.

  2. You can also change this by editing ~/.inputrc (single user) or /etc/inputrc (global)

    set bell-style visible
    

    to change it to flashing and

    set bell-style none
    

    to turn system beeps off.

  3. You can also blacklist the module

    sudo vi /etc/modprobe.d/blacklist.conf
    

    and add

    blacklist pcspkr
    

On my system number 3 is already set as default so I would expect this to be so on your system too. This also seems to be the default method to turn system speaker off.

share|improve this answer
    
This is a laptop, not a desktop. I presume if I turn off the internal speakers, I'll lose all audio output completely. When I've muted the speakers (just using the regular GUI method), this still happens. –  Matty Sep 11 '11 at 13:29
    
You are misunderstanding my reply. Module pcspkr is responcible for system beeps so this is not about the speakers that deal with your sound settings. Muting the speakers does not mute the system beeps. –  Rinzwind Sep 11 '11 at 13:33
    
I understand now. I did all those things, and it's still occurring. It's more of a curiosity than an annoyance. –  Matty Sep 11 '11 at 13:52

I've encountered something similar on some of my older desktop PCs and, as far as I could tell, it had to do with devices being set up to share IRQs without actually being able to play well together.

Given that one of the systems made a clicking noise every time I rolled the scroll wheel while the system was under any kind of non-trivial load, they may be the same thing. (The problem tended to be some form of "input from the keyboard/mouse causes clicking on the audio output" when I encountered it on various PCs)

In my case, fixing the problem was as simple as toggling the "Plug-and-Play OS" setting in the BIOS. That changed which IRQ assignments were done by the BIOS and which by Linux and, in turn, altered IRQ assignments enough to resolve the conflict.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.