Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to set up my ubuntu system to use TOR globally, in all applications, but I can't seem to find any instructions for the newer releases, so everything I find it years out of date. Right now, I have TOR installed from the TOR repositories, as well as privoxy. I followed this set of commands, which don't seem to make much sense anyway.

    sudo aptitude install tor
    sudo  vim /etc/tor/torrc
    sudo  vim /etc/privoxy/config
    comment out: “logfile logfile” and “jarfile jarfile”
    find: listen-address 127.0.0.1:8118
    add (on next line): forward-socks4a / localhost:9050 . (including the period)
    sudo /etc/init.d/tor restart && sudo /etc/init.d/privoxy restart

from this link: https://vocf.wordpress.com/2008/02/18/using-tor-in-ubuntu-torify-our-life/ Basically, I added these two lines to my /etc/privoxy/config:

listen-address 127.0.0.1:8118
forward-socks4a / localhost:9050 .

but I keep getting this error message when I restart the TOR/privoxy server:

Sep 02 19:29:42.471 b780c8d0 Error: Ignoring unrecognized directive  'forward-socks:4a / localhost:9050 .' (314890724ul) in line 729 in  configuration file (/etc/privoxy/config)

I assume the error is because the instructions are for *buntu 6.06, but I can't find any more recent instructions. Any help here? There must be some way of doing this in more recent versions of Ubuntu, right?

Thank you!

share|improve this question

closed as too localized by desgua, fossfreedom Feb 23 '12 at 21:55

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
tor itself recommends polipo to privoxy. Have you tried to setup with polipo ? askubuntu.com/questions/92911/… –  sagarchalise Jan 17 '12 at 2:13

1 Answer 1

up vote 1 down vote accepted

It might be an issue around the spacing in the forward directive. There should be a sample one in the config file prefixed with a '#'. I would comment the one you have and uncomment the preexisting one.

share|improve this answer
    
I had a small error (based on the sample in the file) in /etc/privoxy/config: the forward-socks4a had a colon between socks and 4a which isn't in the sample. However, now I don't get an error message when I restart; it just says fail in red. I tried using forward-socks4a, forward-socks5 but nothing works. –  Ricardo Altamirano Sep 3 '11 at 22:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.