Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to configure my Synaptics driver with a few udev rules regarding the behavior of the TapButton options, and has so far been unsuccessful in doing so. No matter what I type in my .rules file, the driver configuration stays the same, when i do a synclient -l | grep TapButton.

What exactly am I doing wrong? Why is udev so hard to configure? And maybe most importantly, why do I have to do all this, to change the behavior of touchpad tapping?

/etc/udev/rules.d/66-xorg-synaptics.rules :

ACTION!="add|change", GOTO="xorg_synaptics_end"
KERNEL!="event*", GOTO="xorg_synaptics_end"

ENV{ID_INPUT_TOUCHPAD}!="1", GOTO="xorg_synaptics_end"

# synclient for settings

ENV{x11_options.TapButton1}="1"
ENV{x11_options.TapButton2}="2"
ENV{x11_options.TapButton3}="3"

LABEL="xorg_synaptics_end"
share|improve this question
    
What setting are you trying to change? Maybe it's easier through the gui tool. –  Jorge Castro Sep 3 '11 at 14:21
    
There aren't any gui tools to edit TapButton settings, AFAIK. I've tried both xorg.conf and udev, and the driver seems to ignore both. The only way that worked was adding a startup entry to Gnome session. –  mikewhatever Sep 3 '11 at 23:22
add comment

closed as too localized by Luis Alvarado Mar 14 '13 at 15:31

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.