Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried several times to install Natty on its own partition on my laptop (WinXP, Intel x86) using UNetBootin, but it always fail.

There is a dialog box:

Failed to unmount partitions

The installer needs to commit changes to partition tables,
but cannot do so because partitions on the following could
not be unmounted.

/cdrom

Please close any applications using these mount points.

Would you like the installer to try to unmount these partitions again?

If I click on "continue" Ubiquity will hang up, that is, the slideshow will play forever. I do not have a built-in optical drive and I'm not currently using any peripheral.

I have tried sudo umount /cdrom it says that cdrom is busy. Then the command fuser /cdrom returns "Stale NFS file handle".

How can I work around this to install Ubuntu?

share|improve this question
    
can you add a link to a screenshot showing the error? –  fossfreedom Sep 3 '11 at 10:08
    
I have tried but I can no longer open my browser once the install procedure has started, and everything I save is lost when I return to XP... –  Luc125 Sep 3 '11 at 17:05
    
Are you able to install using another method? –  RolandiXor Sep 3 '11 at 18:30
    
Very similar question on superuser. My answer, I believe, may help. superuser.com/questions/152490/… –  Petriborg Sep 8 '11 at 12:00
    
Not really... But it's ok now. Thank you all for your help! And, euh, sorry for not responding for so long, my laptop didn't work anymore. –  Luc125 Sep 8 '11 at 12:00

3 Answers 3

I have also spent hours trying to fix this, even though my problem did not start with UNetBootin. However I got the same result: the installer just quit and said that thing about not being able to unmount /cdrom

Finally the right solution was found at https://help.ubuntu.com/community/Installation/FromLinux

Specifically, do this:

Note2: Instead of using 'workaround', an alternative is to modify the file /etc/mtab by erasing the line that specifies the partition where the cdrom is mounted. This way the kernel thinks thats the /cdrom is not mounted and will not show the advice when installing ubuntu. I think this procedure is less dangerous than the one in the previus note.

Do this before you start the installer. If that does not work, try to do this right before you press the "Install Noew" button.

share|improve this answer
    
Thank you. I will try this when I have to install Ubuntu again... –  Luc125 Oct 19 '11 at 17:18
    
This worked for me Cray, thank you! I know this isn't stackexchange etiquette but this problem has been driving me nuts! –  volni Nov 3 '11 at 5:36
    
This fix still applies to 12.04. Thanks a million. –  user6658 Aug 28 '12 at 19:06
up vote 1 down vote accepted

It is a bug in Ubiquity:

I eventually found those threads after a long, really non-trivial search... Interesting workarounds are listed there. However I won't vouch for them (see comment). Be careful if you need install Ubuntu from an ISO image directly from your disk!

share|improve this answer
    
I tried one of the suggested workaround but it didn't work for me. Maybe I didn't performed it correctly? Anyway, Ubiquity did not freeze this time, but simply crashed. Subsequently I could no longer start my laptop. Visibly the crash had introduced an error in the config of the bootloader (GRUB). This time I really had to get a CD drive. –  Luc125 Sep 8 '11 at 11:38

You are not supposed to use UNetBootin to actually install Ubuntu. You are supposed to use it to put the live CD image onto a flash drive and make it bootable, from which you can then boot and install Ubuntu.

share|improve this answer
1  
This is not true. This install type is called a 'frugal install' and is a supported and documented way of installing Linux using Unetbootin. –  extraneon Mar 20 '12 at 17:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.