Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Does anyone else encounter problem with Clementine's keyboard shortcuts not working ?

I have them assigned to enter image description here

but they do not work. Although for instance the shortcut to open preferences in Clementine Ctrl+P works.

Any ideas/solutions ?

share|improve this question
    
version of clemetine you are using - installed from where? –  fossfreedom Sep 3 '11 at 10:56
    
version is 0.7 downloaded from this site : link version for Natty 64 bits –  Patryk Sep 4 '11 at 17:04
add comment

3 Answers 3

up vote 5 down vote accepted

Met same problem in Ubuntu 11.10 with media buttons shortcuts. "Use Gnome's shortcut keys" didn't worked. So I just set to "Disabled" Gnome's shortcuts for those keys. This solved my problem.

share|improve this answer
3  
Can you tell in details how did you disable gnome's shortcuts ? –  Patryk Sep 21 '11 at 16:44
add comment

Disabling Gnome's shortcut keys only works, if the shortcuts you want to use are not define by the Gnome shortcut system, because clementine cannot fetch the shortcuts.

Therefore we have to deactivate the gnome shortcuts and go to gnome-control-center keyboard to the tab Shortcuts. There deactivate the shortcuts in Sound and Media which you like to control with Clementine. For instance I disable Play (or play/pause), Stop playback, Previous track and Next track. You can deactivate a shortcut by clicking on it and the if there is written New shortcut... press backspace.

Then start clementine, go to tools, preferences to the tab Global Shortcuts. Uncheck the box Use Gnome's shortcut keys. And assigne the shortcuts you want to use to control clementine.

share|improve this answer
    
Perfect step-by-step description, thank you. –  feeela Mar 9 '12 at 22:23
add comment

Open up System Settings, select Keyboard. Go to the Shortcuts tab, click Sound and Media in the left column. For Play (or play/pause), click on Audio Play to change the hotkey.

I changed it to Ctrl + AudioPlay for example, anything un-useful just to be out of the way.

Now (as previously stated) in Clementine, go under Tools -> Preferences -> Global Shortcuts and uncheck Use Gnome's shortcut keys. Then click on Play/Pause to set a new shortcut and press the AudioPlay key.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.