Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to use Cooliris for Google Chrome it shows the following message

WebGL did not initialize properly. Make sure you are running the latest version of Chrome.

I have an AMD/ATI video card. How to fix this? Google Chrome version is 13.0.782.218

http://get.webgl.org/ says "Hmm. While your browser seems to support WebGL, it is disabled or unavailable. If possible, please ensure that you are running the latest drivers for your video card."

Catalyst Control Center says "Catalyst version 11.5 and Driver Packaging Version 8.84.6-110324a-116088C-ATI"

google-chrome --enable-webgl didn't work

share|improve this question
1  
@JaderDias Please make edits to your post instead of posting information in the comments. Doing so will provide a higher quality experience for all users. –  Marco Ceppi Sep 2 '11 at 20:34
    
Firefox now supports webgl and its available on linux :) –  PriteshJ Feb 17 '12 at 19:39
add comment

3 Answers

up vote 8 down vote accepted

WebGL on Google Chrome, it is available BUT not on Linux, actually there's a lot of questions regarding this in Google groups and the Chromium issue tracker. This happens in both x86 and x86-64 versions.

Running google-chrome --enable-webgl --in-process-webgl or google-chrome --enable-webgldoesn't have any effect on the browser.

get.webgl.org Mentions this:

  • Hmm. While your browser seems to support WebGL, it is disabled or unavailable. If possible, please ensure that you are running the latest drivers for your video card.

If you now then go an click on the Wiki link, and then on How to Get a WebGL Implementation you'll see this:

  • Chrome

  • WebGL is available in the stable release of Chrome. Please report issues you find to either the public WebGL mailing list or via the Chromium issue tracker.

THIS is only half-true as neither the stable or the dev. versions of Chrome have WebGL available on Linux. (OP is using the Stable release and i'm using the dev. release)

share|improve this answer
2  
NOTE: one of the google groups messages actually suggests to use firefox if one needs to try webgl, so there is support for linux it's just chrome that doesn't support it. –  Uri Herrera Sep 2 '11 at 18:48
1  
Seems to work just fine on Firefox, any idea why Chrome still doesn't supports it? –  Ghost Apr 5 '13 at 4:12
add comment

Even if the browser you are using is capable of running webgl your computer may not be able to

If you run this command in a terminal

glxinfo | grep "OpenGL version"

You should get back some thing like this

OpenGL version string: 1.5 Mesa 7.9-devel

If the first number is lower than 2.1 you wont be able to run webgl in any browser unfortunately

This is a quote from Benoit Jacob a Firefox developer

Even though WebGL is closest to OpenGL ES v2, every WebGL implementation that I know, including ours, supports desktop OpenGL too, but you need at least OpenGL 2.1 because WebGL is entirely based on the programmable pipeline. So indeed, OpenGL 1.5 is not good enough.

BTW my own card is a ATI Xpress 200M which has a opengl version of 1.5 and I cant use webgl in any browsers.

share|improve this answer
    
some people should need to sudo apt-get install mesa-utils before using glxinfo –  Jader Dias Sep 2 '11 at 19:16
add comment

The following steps allow me to run demos on threejs.org:

On the page chrome://flags/

  • Override software rendering list (select enable)
  • Disable WebGL. (select disable)

You can check that WebGL is enabled by using the following page:

chrome://gpu/

For reference, I am running:

  • Chromium 24.0.1312.56
  • Ubuntu 12.04 (x64, Desktop)
  • ATI Radeon HD 4800 Series
  • OpenGL: 3.3.11627
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.