Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a Magic Mouse, using an Asus Bluetooth dongle.

This is a description of trying it on Natty a few months ago on a Lenovo laptop with Unity, though trying again on Precise on a desktop with Gnome Shell gives me pretty much the same results. The mouse does actually work on Lucid, though I think scroll wasn't supported back then. I try to follow the instructions here:

https://help.ubuntu.com/community/AppleMagicMouse

Though the actual BT preferences wizard diverged slightly at step 6 back when I looked at these instructions for Natty.

  • I bring up the BT preferences.
  • I turn on my mouse, wait for it to start blinking.
  • I click "Set up new device...".
  • It finds my mouse.
  • I click on PIN options and set it to 0000. (note that in Lucid, I don't do this, instead it comes up as a dialog as it's pairing, which does not happen here)
  • I select it and click Forward.
  • It goes through its process and says it's successfully connected.
  • It's now listed as a device in the BT preferences window, but the mouse is still blinking, and doesn't move my cursor.
  • There's an icon, I think implying "connected", that stays on until the mouse gives up on discovery mode and shuts off. (the same icon goes away when I click "disconnect" in the preferences window)

If I try the same thing, but leave the pin on "automatic", it does the same thing, except the "connected" icon only stays on for a second.

Any idea where to go from here?

share|improve this question
    
OP are you still looking for an answer? If so, you may need to repost your question as this is flagged for closure. Regards, –  Ringtail Mar 25 '12 at 18:53
    
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! –  coversnail Apr 10 '12 at 11:51
    
Yes, I've abandoned this. I'm no longer running Natty. Works ok on Lucid, haven't tried on Precise yet. –  orblivion May 22 '12 at 18:41
    
Why would I delete it though? Perhaps somebody has an answer and it could be useful to somebody else? –  orblivion May 22 '12 at 18:42
    
Just tried on Precise Pangolin and failed; updated the description to reflect this. –  orblivion May 25 '12 at 18:05
add comment

1 Answer

An user said to me before that He connects automatically his magic mouse with Blueman application.You can install it from Software Center.

share|improve this answer
    
Also make sure you are connecting to the "Input Service" of the device. –  bert bruynooghe Mar 8 '13 at 8:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.