Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First when I decided to install kubuntu-desktop on the same machine as my standard ubuntu-desktop, I tried to integrate those two in a way that I use some of the same applications on either desktop. I failed doing that because of integration issues (I'm not talking about the look!).

Now I like to try a different approach: I want to separate those two to the max. But I find that either desktop seems to load a lot of programs that have no place nor function in the other one. E.g. Tracker starts alongside with the Strig/nepomuk stuff, Dropbox seems to load half of gnome into KDE and kwallet starts in gnome even when no application tries to access it. Gnome keyring on the other side starts with KDE for a good reason, but I can't set it up to use my login password as authentication without entering it again to start the keyring.

What are the right settings to separate the two desktops to the maximum possible extent? Where are the files controlling this? For example I tried to use LightDM to have no gdm or kdm running but it seems to mess up some things like keyboard bindings ...

Is there a tutorial out there that I couldn't find while googling? Any comprehensive information should help!

share|improve this question

2 Answers 2

up vote 4 down vote accepted

Unfortunately, once the two Desktop Environments are on the same installation (using the same or different directories), there is no real way to separate them.

The only way to get them "completely separated" is to install them on two separate installations. I'm sorry that it is that way, but essentially that's what it boils down to.


In light of your comment, there is an option you can add to the .desktop files that prevents them from showing in specific environments.

I believe this setting should be "OnlyShowIn" and the value would be KDE, GNOME, Unity, etc.

In KDE it is possible to set this manually for your startup applications (but only for KDE itself).

share|improve this answer
    
thx! Maybe I was too demanding here. More specific: e.g. how do I stop tracker-store & tracker-miner from starting in the background of Kde and nepomuk/strigi from starting with gnome? There should be a correct setting within ~(.config/autostart ... but I don't find that. –  piedro Sep 13 '11 at 13:16
    
@piedro: see my edit. –  RolandiXor Sep 13 '11 at 15:16

I found a solution on this site

on /etc/xdg/autostart , there are:

  • tracker-miner-flickr.desktop
  • tracker-miner-fs.desktop
  • tracker-store.desktop

edit them with OnlyShowIn=GNOME;

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.