Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I installed Ubuntu 11.04 it suggested I should use the proprietary STA driver, so I did. This caused a lot of problems and I spent hours troubleshooting. I then tried removing the driver by unchecking the driver in Additional Drivers and now everything works fine.

Obviously Ubuntu recommends the STA driver but the other driver seems to work much better. All documentation I find about Ubuntu and BCM4313 also suggests the STA driver.

Why is the STA driver recommended?

What is the advantage of using that driver?

Will it cause problems when not using the STA driver?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

I think the recommendation of using the STA driver is because the open source driver brcm80211 is still considered unstable. It is in the 'staging' area of the kernel.

For example, my machine (which also has a BCM4313) freezes if I toggle the hardware switch. (this has been fixed in the Oneiric kernel.) The open source driver does give a more stable connection than the STA driver, though, especially with WPA/Enterprise connections.

My recommendation is to use the open source driver. It works better for me, and from your question I gather that it works better for you as well. And it is open source, too.

share|improve this answer
    
So, the STA driver used to be better but the open source driver is better today? All available documentation still recommends the STA driver and should be updated. –  danne Sep 2 '11 at 11:53
1  
@danne: I cannot speak for every hardware and network configuration. But it appears that in the case of yours and mine, you are right. Unfortunately, googling usually gives a lot of obsolete recommendations (on forums for instance) and that's difficult to change. You could try contacting the maintainers of the documentation you're referring to. –  Timo Kluck Sep 2 '11 at 12:49

With brcmsmac driver your wifi should work fine but it only supports managed and monitor mode. There is no support for ad-hoc, access point and bridges yet. So a better option is use a "wl0" driver which supports managed and ad-hoc modes plus bridges and works much better. Procedure for installation:

1-sudo apt-get install bcmwl-kernel-source

or you can install it from synaptic manager also, make sure broadcom-sta-common, broadcom-sta-source, firmware-b43* are NOT INSTALLED.

2-Even if you install the wl0 driver it won't load automatically as it is blacklisted by default. So make sure "/etc/modprobe.d/blacklist-bcm43.conf" file looks like this:

# Warning: This file is autogenerated by bcmwl. All changes to this file will be lost.

blacklist b43

blacklist b43legacy

blacklist ssb

#blacklist bcm43xx

#blacklist brcm80211

blacklist brcmsmac

blacklist bcma

3-If you wish you can copy above contents in your blacklist-bcm43.conf file.

4-Hope this works, best of luck! and make sure you restart your pc.

share|improve this answer
    
Hi, Its quite off-topic here. But can we create an infrastructure AP with wl0 driver for BCM4313? –  Log1c Oct 1 at 13:13

I have the same problem with my netbook. The thing is when you install sta drivers, the other alternatives become blacklisted so you won't have the choice to use the b43 (or bc43, don't remember exactly the name) driver.

Try this:

cat /etc/modprobe.d/blacklist.conf

You'll see there which modules are blacklisted. If you see there something refering to the broadcom drivers, edit the file:

Make a backup copy, for if you need to revert the changes:

sudo cp /etc/modprobe.d/blacklist.conf /etc/modprobe.blacklist.conf_backup

Open it:

sudo vim /etc/modprobe.d/blacklist.conf

or if you feel more confortable with a gui:

gksu gedit /etc/modprobe.d/blacklist.conf

Search the line than refer to the broadcom driver and coment it (adding # at the beginning) Save the changes and reboot. Now you should see a new option in additional drivers.

In case it doesn't work, just revert the changes by:

sudo cp /etc/modprobe.d/blacklist.conf_backup /etc/modprobe.d/blacklist.conf

You should also try to reinstall the sta driver and see if it works better:

sudo aptitude reinstall bcmwl-modaliases

Good luck!

share|improve this answer
    
lspci -v says: "Kernel driver in use: brcm80211 Kernel modules: brcm80211" so I guess the open source driver is already activated and working. [user@host] ~> grep 43 /etc/modprobe.d/blacklist.conf # replaced by b43 and ssb. blacklist bcm43xx –  danne Sep 2 '11 at 11:51
    
i do not understand. does this answer really work? –  lujbilami Apr 4 '12 at 14:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.