Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Most of the films I watch on my PC are in HD, those of 20GB or more, even between 50-72GB. On Windows I can play all those films without problem.

Some of them are .mkv and others are bdmv.

I did not install any driver from catalyst or from Additional Drivers. Nevertheless I have direct rendering:

mortuus@alliancecore:~$ glxinfo | grep direct
direct rendering: Yes

I've tested it with VLC 1.1.9 (with and without GPU acceleration), smplayer, totem and moovida center. None was successful.

My specs:

  • AMD Phenom II X4 905e 2'5GHz
  • RAM 4GB
  • ATI Radeon HD4890
  • My resolution is 1920x1080

Thanks in advance

share|improve this question

closed as too localized by jrg Feb 29 '12 at 0:56

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Does the videos play without a hassle in Windows without the driver catalyst or proprietary installed? Do you have direct rendering in Windows without the driver installed? I don't know how can Windows handle such a overload of graphics without drivers installed but if you have the proprietary driver installed in Windows, try installing it on Ubuntu. It seems that you own a beautiful piece of art with that Radeon HD4890, but I don't think it will work as expected without the proprietary driver installed. Sorry if I misunderstood your question but further information will be useful next time. –  Geppettvs D'Constanzo Sep 2 '11 at 15:33
    
Additionally you may wish to run a search on similar questions, whose answers may give you a clue on how does Ubuntu handle these tasks, like the answers provided in this question: askubuntu.com/questions/28078/smooth-fullscreen-1080p-playback Good luck! –  Geppettvs D'Constanzo Sep 2 '11 at 15:35
    
Hi! Thanks for you reply. In Windows I have propietary drivers (Catalyst). In Ubuntu I tried to install open source drivers (from Additional Drivers) but it breaks my desktop configuration, all becomes unusable. So I'm afraid of trying propietary drivers, because they're not as easy for uninstalling (I think). So maybe that's the problem? I'll do little more research –  aesptux Sep 2 '11 at 21:41
1  
@aesptux Just keep updating your question with things you've tried, it'll help rule out solutions that don't work, good luck! –  Jorge Castro Sep 3 '11 at 14:30
    
Absolutely agree with @Jorge Castro, but I am sure that you won't enjoy the highest experience when playing high definition video without proprietary drivers correctly installed. Unfortunately I can't say for ATI's. I am for nVidias. Additionally, a search provide you with lots of useful tips and experiences from other users, which I expect they are also useful for you. askubuntu.com/search?q=install+ati+driver Good luck! –  Geppettvs D'Constanzo Sep 3 '11 at 16:29

2 Answers 2

Well, i already had that problem in my pc. what i did was to install SmPlayer and configuring it. Going menu, preferences,general, and in the video tab, select (gl- fast- Ati cards). then when you want to see a movie open it with smplayer and i think it will be fixed. If not, tell-me something.

share|improve this answer

Hi i have a simular setup and also got lag with my screen resulotion at 1920 x 1080 because i only could pick 25 Hz and 30 Hz maximum. The TV got the 1080i singal

I have changed my 1280 x 768 at 60 Hz and no lag anymore... also widescreen option in totem player made my TV work at 1080i (hd ready TV) at this resolution.

i chose to go for an image without lag instead of full pixels at 30 Hz with a little lag. My screen is 108 cm in with.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.