Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using ASPIRE 4750G, with processor of Intel Core i5. Currently I'm using Ubuntu 11.04 - the Natty Narwhal. I would really need some guide how to fix these problems:

  1. I can't hear any sound after plug-in earphone.
  2. I can't adjust the screen brightness.

Thank you.

share|improve this question
    
About sound: Don't know. About Brightness: What's your graphics set? Nvidia? Intel i915 perhaps? Acer specs indicate Nvidia GeForce® GT 540M. Please advise.<br>s –  Dan Taylor Oct 24 '11 at 0:06
    
UPDATE: Could be related to [link] (bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/…) See where it talks about adding acpi_backlight=vendor to the kernel command line to fix brightness. –  Dan Taylor Oct 24 '11 at 0:16

2 Answers 2

I too have the Acer Aspire 4750G, however I use Linux Mint 11, though it is based on Ubuntu 11.04. I too also can't adjust brightness, however I was able to fix the plug-in earphones to work, or the headphone jack. The way I was able to fix it was that in the BIOS, I changed the graphics card from switchable to integrated, and all of a sudden the headphone jack started working. But if you want to play games in Windows, you have to switch the graphics card from integrated to switchable. I'm not sure why changing the graphics card settings affected the headphone jack. If sound doesn't work when you changed it, go to sound preferences and in hardware make sure Analogue Stereo Duplex is selected and in output select Analogue Speakers.

I'm not sure why changing graphic card settings fixed my headphone jack, but it might be because the Intel chip controls the headphone jack and when you use switchable, and since nVidia Optimus is not supported officially in Linux, that some aspects of the Intel chip like sound cannot be used. Hope this fixes it!.

share|improve this answer

You may want to try the following and see if it will fix the brightness control after a reboot:
Sudo edit the file etc/X11/xorg.conf and add the line Option "RegistryDwords" "EnableBrightnessControl=1" to the Screen section.

E.g.

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "RegistryDwords" "EnableBrightnessControl=1"
    Option         "NoLogo" "True"
    SubSection     "Display"
        Depth       24
    EndSubSection 
EndSection
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.