Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I asked the same question when I used Maverick Meerkat but I can't make that solutions work on Unity. I want to use the keys ´ followed by c and the output should be "ç". It works that way in Windows out of the box, and it did work in Ubuntu 10.10 following the solutions given in the question above. But in 11.04 it outputs "ć". How to change that?

share|improve this question

8 Answers 8

up vote 5 down vote accepted

Edit /usr/lib/gtk-2.0/2.10.0/gtk.immodules Modify the line where you can find "cedilla" add ":en" at the end

"cedilla" "Cedilla" "gtk20" "/usr/share/locale" "az:ca:co:fr:gv:oc:pt:sq:tr:wa:en"

Edit /etc/environment Add: export GTK_IM_MODULE=cedilla


Edit for Ubuntu 12.10: (according to the other answer by Hoerlle)

the gtk.immodule file is located at:

/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/gtk.immodules

or

/usr/lib/i386-linux-gnu/gtk-2.0/2.10.0/gtk.immodules


For KDE and other applications that are not GTK: Edit: /usr/share/X11/locale/en_US.UTF-8/Compose

Find all ocorrencies for ć and replace it all for ç, remember to look for the the uppercase matches too Ć and Ç

You may need to restart your gnome.

share|improve this answer

In Ubuntu 13.10, I fixed it by adding the following lines in /etc/environment:

GTK_IM_MODULE=cedilla 
QT_IM_MODULE=cedilla 
share|improve this answer
    
For me, in Ubuntu 13.10 and Gnome Shell, worked too. –  euDennis Jan 21 '14 at 10:04

Use the accent, not the apostrophe:

accent + c (´+c) = ç trencada

share|improve this answer
    
I was using the accent <kbd>´</kbd> all the time, but the question didn't reflect it, so I edited the question, invalidating your answer. Sorry –  Jader Dias Sep 2 '11 at 14:08

In Ubuntu 12.10 the gtk.immodules file to be edited are located at:

/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/gtk.immodules

or

/usr/lib/i386-linux-gnu/gtk-2.0/2.10.0/gtk.immodules

share|improve this answer

Try using the Dvorak International layout with dead keys;there's a good possibility that QWERT International with dead keys also uses these keys. On mine, the comma is a live key. (It's used often enough that it would be annoying if it were a dead key.)

For a ç. try AltGr (right Alt) + ,. For a capital, Ç, try Shift+AltGr+,.

share|improve this answer
1  
using Dvorak might be more annoying than a dead comma key for people that are used with QWERT –  cipricus Apr 17 '13 at 9:33

Using the same answer for the same question found here: How do I make Cedilla (ç) character available in English USA?

If you're in a hurry, do this and you'll get "ç" instead of "ć":

Press "AltGr + ," then "c".

If you want to know a bit more, keep on reading.

This may be solved already by using one of the answers above, but I realized the best thing to do is to use the keyboard layout, instead of changing things you'll have to eventually change again in the future (after updates, for example).

Before I start, keep in mind I'm using Ubuntu 14.04.2, which is not the same distro as the original question mentions (11.04). Anyway, I believe most users have already migrated to newer versions by now. So:

$ cat /etc/issue
Ubuntu 14.04.2 LTS \n \l

Okay, the first thing I did was looking at the immodules files:

/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules.cache /usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/immodules.cache

At the header, those files clearly mention they should not be changed, since they're generated automatically:

# GTK+ Input Method Modules file
# Automatically generated file, do not edit
# Created by /usr/lib/x86_64-linux-gnu/libgtk-3-0/gtk-query-immodules-3.0 from gtk+-3.10.8

So changing them, although it may solve the problem temporarily, is not ideal.

Looking around, I found the best answer ever about why we get a "ć" instead of a "ç" when typing ' + c: because we're really putting an acute accent on the top of letter "c". So the layout is right. With that in mind, how would one put a "kind of a" comma at the bottom of the letter "c"? Using a comma, of course!

So, the solution was the key combination AltGR + , and then "c".

No need for changing any configuration on your computer.

share|improve this answer

In Xfce 12.10 I have solved it by installing ibus package and its dependencies.

This is a bug reported here (and the solution is mentioned in a comment - more specifically here.)

share|improve this answer

In Kubuntu 15.04, after replacing cedillas for the /usr/share/X11/locale/en_US.UTF-8/Compose as described by others above, only qt-based apps were OK. After that, I installed ibus-gtk and ibus-gtk3 and it fixed my problem to firefox and other gtk-based apps as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.