Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

First off I did something stupid. I downloaded a Nvidia driver even though I have an integrated chipset. After installation my unity was still working. However, when I restarted my computer I got an error message saying that I can't run unity.

I uninstalled the Nvidia driver.

I restarted my computer.

Unity still does not work.

In the terminal I type "unity" and everything looks okay until I get three error messages that say this:

Xlib:  extension "GLX" missing on display ":0.0".

followed by:

Compiz (opengl) - Fatal: glXCreateContext failed
Compiz (bailer) - Info: Ensuring a shell for your session
jesse@jesse-PC:~$ Cannot register the panel shell: there is already one running.
share|improve this question

closed as too localized by desgua, fossfreedom Feb 24 '12 at 14:09

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) – fossfreedom Feb 24 '12 at 14:09

Logout and, before log back in, make sure to choose Ubuntu instead of Ubuntu Classic.

share|improve this answer
Didn't work desgua. I ran it in the terminal then tried "unity" and it came up with same errors. – Jesse Sep 2 '11 at 0:41
Can you get to a graphical environment? – desgua Sep 2 '11 at 0:51
I am working in ubuntu now as selected when I logged on.. same as I always have.. it just looks different. I cannot manage windows like I used to and there is no sidebar. – Jesse Sep 2 '11 at 1:11
Run jockey-gtk to see if a driver can be installed to enable 3d acceleration. – desgua Sep 2 '11 at 1:23
If it doesn't help, you can try to logout and, before log back in, make sure to choose Ubuntu instead of Ubuntu Classic. – desgua Sep 2 '11 at 1:24

You need to install the mesa-glx package.

sudo apt-get install libgl1-mesa-glx libgl1-mesa-dri

Then, restart, and you should be fine.

share|improve this answer

first of all check if you have completely removed nvidia drivers

then install intel-gpu-tools and i965-va-driver

sudo apt-get install intel-gpu-tools
sudo apt-get install i965-va-driver

I hope this should work

you may need to reinstall unity and logout for change in effects

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.